Download it now!
Bug 133434 - When merging cells that have a border applied, right border will reset
Summary: When merging cells that have a border applied, right border will reset
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Border
  Show dependency treegraph
 
Reported: 2020-05-27 11:26 UTC by vytas.naus
Modified: 2020-08-25 19:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vytas.naus 2020-05-27 11:26:09 UTC
Description:
Lets say there's 3 cells - 1, 2, 3. Cell 1 has left border applied, cell 3 has right border applied. When merging these cells, cell 1 retains it's border, while cell 3 has it's border reset.

Steps to Reproduce:
1. apply left border to cell B1, right border to cell D1.
2. merge these cell.

Actual Results:
cell B1 retains left border, cell D1 doesn't retain right border.

Expected Results:
Both borders are retained, as they're not in conflict with the merge.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.5.2
Build ID: 6.3.5.2-5.fc31
CPU threads: 16; OS: Linux 5.5; UI render: default; VCL: gtk3; 
Locale: en-IE (en_IE.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 ld_secondary 2020-06-27 10:22:42 UTC
Confirmed for version 6.4.3.2
Comment 2 Roman Kuznetsov 2020-08-25 18:59:53 UTC
I think it's because merged cell has the format from first up-left cell from selected range for merge.

Mike, what's your opinion here?
Comment 3 Mike Kaganski 2020-08-25 19:12:43 UTC
Yes, only in simplest cases there are cell borders that alone fully define some resulting border. Normally, each border of merged cell is originally represented by borders of several cells; e.g. 2x2. Each such cell may have own border ... so either we create complex rules that would definitely result in surprises for many, and anyway will cause reports because of "wrong" behaviour, or we keep it simple: just use the formatting of the first cell.

IMO - WONTFIX. Just because any strategy here is no better, but this one has advantage of being simple, both in implementation, and in understanding.
Comment 4 Roman Kuznetsov 2020-08-25 19:20:14 UTC
Thanks, Mike. Let's close it as WONTFIX