Download it now!
Bug 133441 - FILEOPEN: DOC: Hang at import time of table in table
Summary: FILEOPEN: DOC: Hang at import time of table in table
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks:
 
Reported: 2020-05-27 13:23 UTC by Xisco Faulí
Modified: 2020-06-10 16:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-05-27 13:23:44 UTC
Steps to reproduce:
1. Open attachment 52300 [details] from bug 41748

-> LibreOffice hangs forever ( killed after 11 minutes)

Reproduced in

Version: 7.0.0.0.alpha1+
Build ID: 82894d85147840f1f587e9530b12f0058f2ef2c3
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded


[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2020-05-27 13:27:49 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=aa5dc0b48cd4db6883c9b52c68b16170c9c81d1f

author	Justin Luth <justin.luth@collabora.com>	2020-05-04 13:16:32 +0300
committer	Miklos Vajna <vmiklos@collabora.com>	2020-05-11 10:14:19 +0200
commit	aa5dc0b48cd4db6883c9b52c68b16170c9c81d1f (patch)
tree	7a1bb6161ef3bad60db5c1093a1a5c7d2e9dcec8
parent	356edfa963bd1d1c8e081a012e6a2ccbe7bf53d3 (diff)
tdf#105478 sw layout: treat minHeight as "do not split row"

Bisected with: bibisect-linux64-6.5

Adding Cc: to Justin Luth
Comment 2 Justin L 2020-05-27 18:27:18 UTC
Created attachment 161353 [details]
A table in table with a minimum row height.doc

Comment 0's example document is a table-in-table-in-table nightmare. However, my simple example document shows that I can't ignore minimum row height simply because it is table-in-table.  Too bad.

LO could open a version that was first round-tripped by Word 2003, but that isn't really important. But it suggests that this just happens to trigger a layout state that LO can't handle. I'm not sure what to do or try next.
Comment 3 Justin L 2020-05-30 11:30:17 UTC
A revert patch is queued up at https://gerrit.libreoffice.org/c/core/+/95180, which will be my fallback if this cannot be properly fixed.
Comment 4 Justin L 2020-06-03 13:50:09 UTC
patch has been reverted.
Comment 5 Xisco Faulí 2020-06-09 10:43:05 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: e0f058bcd5e185b89e4b7c680a7901bc7eb2a790
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Justin L, thanks for fixing this issue!