Bug 133531 - Crash on undo after paste of external copy
Summary: Crash on undo after paste of external copy
Status: RESOLVED DUPLICATE of bug 134693
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-30 21:21 UTC by Wil Hostman
Modified: 2020-12-21 10:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Srashig PDF (378.38 KB, application/pdf)
2020-12-21 10:05 UTC, Martin Srdoš
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wil Hostman 2020-05-30 21:21:27 UTC
Description:
After pasting rich text from a PDF, an immediate undo (wrong location, wanted to paste plaintext only, etc) results in a crash.
The document recovers afterwards.
Fatal error, exits gracefully.

Steps to Reproduce:
1. Copy rich text from a PDF. 
2. Paste into writer document.
3. Undo.

Actual Results:
Program crashes, goes to crash-report.

Expected Results:
Return to state prior to paste.


Reproducible: Always


User Profile Reset: No



Additional Info:
I have experienced this several dozen times.
Comment 1 Telesto 2020-05-30 21:48:06 UTC
Thanks for reporting. Which PDF reader are you using? Acrobat Reader?
And does it happen with any file, or could you attach an example
Comment 2 QA Administrators 2020-11-28 04:29:11 UTC Comment hidden (obsolete)
Comment 3 Wil Hostman 2020-11-29 05:00:13 UTC
Both acrobat reader and the in-chrome viewer.
Comment 4 QA Administrators 2020-11-30 03:49:05 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2020-11-30 14:56:04 UTC
Hello Wil Hostman,
Please, attach a pdf that causes LibreOffice to crash
Comment 6 Wil Hostman 2020-12-01 02:54:21 UTC
I cannot legally provide any of the PDFs that do so - they are copyrighted content.
However, they include the Legend of the Five Rings RPG rulebook PDF (purchased on DriveThruRPG.com), and the Stargate SG-1 Beta from https://stargatetherpg.com/files/file/16-stargate-rpg-public-beta-rules/

More than a dozen other PDFs have done so. (Most of them purchased through DriveThru RPG.com)

The trigger is copying styled text, then pasting it into a table, then using a control-z to undo. It's not entirely consistent, but it has been especially troublesome with tables using the area select in Acrobat Reader (current edition).

Note that this bug has happened under both Mac OS X 10.14 and Win 10.
Comment 7 QA Administrators 2020-12-01 03:53:30 UTC
[Automated Action] NeedInfo-To-Unconfirmed
Comment 8 Martin Srdoš 2020-12-21 10:05:08 UTC
Created attachment 168373 [details]
Srashig PDF

I am testing this bug with this PDF. If I use Adobe Acrobat then the Writer crash. If I use Chrome, Firefox or Okular (an opensource pdf reader) then there is no crash. But only by adobe acrobat copying there is copyed rich text. The others programs copy only unformated text.
Comment 9 Martin Srdoš 2020-12-21 10:07:29 UTC
I see it so, this is duplicate of bug 134693. So I set it like RESOLVED DUPLICATE.

*** This bug has been marked as a duplicate of bug 134693 ***
Comment 10 Martin Srdoš 2020-12-21 10:11:16 UTC
I have forgotten to test it in master.

So, in master it works ok:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 59301a1cadd87a63276650975252d14e8477e632
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: cs-CZ (cs_CZ); UI: en-US
Calc: threaded

But there is the bug in last release:
Version: 7.0.4.2 (x64)
Build ID: dcf040e67528d9187c66b2379df5ea4407429775
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: cs-CZ (cs_CZ); UI: en-US
Calc: threaded