Bug 133567 - LibreOffice Impress does not allow setting multiple animations at once
Summary: LibreOffice Impress does not allow setting multiple animations at once
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-31 20:14 UTC by Tianxing Yang
Modified: 2021-11-26 14:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test case. Slide 2 is a screenshot of the problem. (108.64 KB, application/vnd.oasis.opendocument.presentation)
2020-05-31 20:14 UTC, Tianxing Yang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tianxing Yang 2020-05-31 20:14:16 UTC
Description:
LibreOffice Impress does not allow setting multiple animations at once. This does not allow me to change the animation effects of multiple objects at once. I have set it one by one, which is very time consuming and frustrating.

Steps to Reproduce:
1. Open a new presentation and add some random text.
2. Choose 2 or more objects and add animation to them.
3. Change the animation of these objects.

Actual Results:
The Effect, Direction, Duration, Delay entries are all grayed out and disabled.

Expected Results:
1. If the selected items have the same effect, direction, duration, or delay, the corresponding value should be displayed accordingly. If they have different values, the displayed value shall be undecided and allow editing.
2. When I change any one of these entries, the change shall propagate to the selected objects at once, the same as in Microsoft PowerPoint.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.3.2
Build ID: 1:6.4.3-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Tianxing Yang 2020-05-31 20:14:46 UTC
Created attachment 161476 [details]
Test case. Slide 2 is a screenshot of the problem.
Comment 2 johnks 2020-07-05 18:15:19 UTC
yes. i confirm that in my 6.4.5.2, i am unable to set a single animation to more than one element. i have to do all elements one by one and then use the "with previous/after previous" to get the desired effect. This is really clunky. if i select multiple objects, i expect them to be animated together as one, otherwise i wouldn't select them in the first place
Comment 3 Niha 2020-07-08 19:39:55 UTC
I also confirm this and I have also tested it in prerelease version 7.0.0 and this feature is missing in that too. Impress does not allow to change animation property multiple objects at once.
Comment 4 Kai 2020-07-22 00:50:31 UTC
Can also confirm this in 7.0RC2.
Comment 5 Davi Caixeta Carvalho 2021-11-26 14:19:10 UTC
I have the same problem on Impress. All previous versions I used in those years also had this problem.

I also believe that there should be a way to define the default type of animation you want so you don't have to keep setting up object by object every time.

Version: 7.0.4.2
Build ID: 00(Build:2)
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: x11
Locale: pt-BR (pt_BR.UTF8); UI: en-US
SlackBuild for 7.0.4 by Eric Hameleers
Calc: threaded