Bug 133600 - QR code generator dialog shows three of the four radio buttons selected
Summary: QR code generator dialog shows three of the four radio buttons selected
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All Windows (All)
: medium minor
Assignee: Gabor Kelemen
URL: https://bbs.libreofficechina.org/thre...
Whiteboard: target:7.1.0 target:7.0.0.2 target:6.4.6
Keywords:
: 135428 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-06-02 11:56 UTC by zh_CN User Community Liaison
Modified: 2020-08-04 07:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing the problem (5.69 KB, image/png)
2020-06-02 11:56 UTC, zh_CN User Community Liaison
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zh_CN User Community Liaison 2020-06-02 11:56:36 UTC
Created attachment 161518 [details]
Screenshot showing the problem

This bug is forwarded and translated from a report in a Chinese user forum, original report (in Chinese) at: https://bbs.libreofficechina.org/thread-2489-1-1.html

When a user invokes the QR Code Generator dialog (Insert > Object > QR Code...), the dialog would show three of the four radio buttons selected initially, instead of only one.  See attached screenshot.

Clicking on any of the options seems to get the radio buttons returning to correct behavior.

The original report was for 6.4.4 on Windows 10.  I can reproduce with 7.0.0 beta1:
Version: 7.0.0.0.beta1 (x64)
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
CPU 线程: 2; 操作系统: Windows 10.0 Build 18363; 用户界面渲染: Skia/点阵; VCL: win
Locale: zh-CN (zh_CN); UI: zh-CN
Calc: threaded
Comment 1 Julien Nabet 2020-06-02 12:42:02 UTC
On pc Debian x86-64 with LO Debian package 6.4.4, I could reproduce this with gen rendering, not with gtk3 or kf5 rendering.

With master sources updated, I can reproduce this with gen and kf5 rendering.
Comment 2 Julien Nabet 2020-06-02 12:57:18 UTC
On Win10 with master sources updated today, I don't even see the radiobuttons, just the labels.
Comment 3 yanjingtao 2020-06-03 03:43:33 UTC
Reproduce in 7.0 beta1 and no reproduce in 6.4.4.1.

版本: 6.4.4.1 (x64)
Build ID: b50bc319eca5cd5b66fbfe2ebd0d3bd1eed099b5
CPU 线程: 8; 操作系统: Windows 10.0 Build 19041; UI 渲染: GL; VCL: win;
区域语言: zh-CN (zh_CN); UI 语言: zh-CN
Calc: CL

Version: 7.0.0.0.beta1 (x64)
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
CPU 线程: 8; 操作系统: Windows 10.0 Build 19041; 用户界面渲染: Skia/Vulkan; VCL: win
Locale: zh-CN (zh_CN); UI: zh-CN
Calc: CL
Comment 4 Gabor Kelemen 2020-06-04 20:40:04 UTC
Proposed patch: https://gerrit.libreoffice.org/c/core/+/95540
Comment 5 lol 2020-06-14 14:47:35 UTC
I can reproduce this in 6.4.4.2 and 7.0.0.0beta1.

Version: 6.4.4.2 (x86)
Build-ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU-Threads: 2; BS: Windows 6.1 Service Pack 1 Build 7601; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

Version: 7.0.0.0.beta1 (x64)
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
CPU-Threads: 4; BS: Windows 10.0 Build 18362; UI-Render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded
Comment 6 Commit Notification 2020-07-07 02:42:53 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/06f1f8d817a2ea86e29bbef7cf0995ce337c56be

tdf#133600 Only one button selected by default in QR code dialog

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2020-07-07 08:58:22 UTC
Hi Gabor,
after your patch, the default selected option is 'Low', should it be defaulted to Medium ?
Comment 8 Commit Notification 2020-07-07 15:30:37 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/654f5316015a38b5c720a93305d21f63aa9697eb

tdf#133600 Only one button selected by default in QR code dialog

It will be available in 7.0.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Adolfo Jayme 2020-07-08 20:15:00 UTC
W.r.t. comment 7, please file a separate bug for that.
Comment 10 Gabor Kelemen 2020-07-08 20:30:01 UTC
(In reply to Xisco Faulí from comment #7)
> Hi Gabor,
> after your patch, the default selected option is 'Low', should it be
> defaulted to Medium ?

I have a 2 weeks old version at hand from bibisect-linux-64-7.1 which also has Low selected by default, so this is an unrelated issue.

Version: 7.1.0.0.alpha0+
Build ID: 10129e2dfc582915d999e24deed34f7303a6f02e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: hu-HU (hu_HU.UTF-8); UI: en-US
Calc: threaded
Comment 11 Commit Notification 2020-07-12 22:36:48 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/2c4baf124c1cf8ee2f7f45282eca3ee683dc7e9f

tdf#133600 Only one button selected by default in QR code dialog

It will be available in 6.4.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Julien Nabet 2020-08-04 07:58:38 UTC
*** Bug 135428 has been marked as a duplicate of this bug. ***