Download it now!
Bug 133641 - CRASH: after clicking on a drop-down form
Summary: CRASH: after clicking on a drop-down form
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All All
: high major
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.1.0 target:7.0.0.1 target:6.4.5
Keywords: bibisected, bisected, haveBacktrace, needUITest, regression
Depends on:
Blocks:
 
Reported: 2020-06-03 16:36 UTC by Xisco Faulí
Modified: 2020-07-03 17:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (26.50 KB, application/msword)
2020-06-03 16:36 UTC, Xisco Faulí
Details
bt with debug symbols (5.37 KB, text/plain)
2020-06-03 17:09 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-06-03 16:36:28 UTC
Created attachment 161584 [details]
sample file

Steps to reproduce:
1. Open attached document
2. Double click on the form ( Borgoin-Jallieu )

-> Crash

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 8d0b7e5b2f6773f4b3feb75f1ac73ea1a26609f7
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-06-03 16:37:47 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=1c94842e053a20a739a181d38a35c324df3e62a7

author	Michael Stahl <Michael.Stahl@cib.de>	2020-04-15 16:58:55 +0200
committer	Michael Stahl <michael.stahl@cib.de>	2020-04-15 19:59:33 +0200
commit	1c94842e053a20a739a181d38a35c324df3e62a7 (patch)
tree	0c584b905158f3b3d8032735b01a377d17462f1a
parent	54c94ddff2664bc378a4298ee4d6948b7f32e595 (diff)
tdf#132091 sw: fix fieldmark mess in SwCursor::SelectWordWT()

Bisected with: bibisect-linux64-6.5

Adding Cc: to 1c94842e053a20a739a181d38a35c324df3e62a7
Comment 2 Julien Nabet 2020-06-03 17:09:20 UTC
Created attachment 161585 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
It's an assertion but since we try to dereference "ret" variable just after the assert instruction, it's related.
Comment 3 Commit Notification 2020-06-10 08:43:03 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cb28054d831c38ef645f635ecd80475fb5735679

tdf#133641 sw: fix crash double-clicking CH_TXT_ATR_FORMELEMENT

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Michael Stahl (CIB) 2020-06-10 08:51:21 UTC
fixed on master
Comment 5 Commit Notification 2020-06-10 13:46:58 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/16764e33a7772d26ec24185a51472e68c6b371c5

tdf#133641 sw: fix crash double-clicking CH_TXT_ATR_FORMELEMENT

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-06-10 21:55:39 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/ce7ced5b7cbadb980adbb3998efa15a369d5a544

tdf#133641 sw: fix crash double-clicking CH_TXT_ATR_FORMELEMENT

It will be available in 6.4.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2020-06-11 08:53:43 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 03b77f972f6be23f75dfe3773266a660e61e5607
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Michael S, thanks for fixing this issue!!
Comment 8 Commit Notification 2020-06-15 01:51:43 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-5":

https://git.libreoffice.org/core/commit/2684ce9dff3f122bc95481c420607c9f99dd22a0

tdf#133641 sw: fix crash double-clicking CH_TXT_ATR_FORMELEMENT

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 elshreif 2020-07-03 12:35:37 UTC
I am trying to add support for "Double-clicking on forms" in the UITest framework to be able to create test case for this bug. But I need more details about how to create a form or what do we mean by forms in general.

Thanks
Comment 10 Michael Stahl (CIB) 2020-07-03 17:04:42 UTC
<mst___> elshreif, in this case "form" means a drop-down fielmark, you can insert it via the Forms menu, but you first have to reconfigure it to show "MS-compatible forms menu" somewhere in Tools->Options... probably it's easier to insert it via the API
<mst___> elshreif, i think the service is com.sun.star.text.FormFieldmark