Download it now!
Bug 133646 - Export to PDF uses 45 MB more memory on export and without being purged after export or close
Summary: Export to PDF uses 45 MB more memory on export and without being purged afte...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf
Depends on:
Blocks: Memory
  Show dependency treegraph
 
Reported: 2020-06-03 19:21 UTC by Telesto
Modified: 2020-06-18 15:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Bibisect log (2.77 KB, text/plain)
2020-06-03 19:25 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-03 19:21:28 UTC
Description:
Export to PDF 45 MB more memory on export and not purged after export or close

Steps to Reproduce:
1. Open attachment 160498 [details] and take notice of the memory usage of soffice.bin
2. Export the file to PDF default settings (export button in menu bar) and monitor memory usage
3. Close the document and monitor memory usage of start center

Actual Results:
6.1 origin/master
Open 92
Export 206
Close 105

6.2 origin/master
Open 150
Export 260
Close 163

Expected Results:
Purge after export
Purge after close of document


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 Telesto 2020-06-03 19:25:24 UTC
Created attachment 161592 [details]
Bibisect log

Bug 133645 explains the bump form 
Export from 206 to 236 
Close from 105 to 128

This bibisect explains the bump from
From 236 to 260 at export to PDF
From 128 to 163 at close of the doc

Bisected to
author	Miklos Vajna <vmiklos@collabora.co.uk>	2018-09-07 10:43:10 +0200
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2018-09-07 16:02:49 +0200
commit	2a73c9e04ba9379c0561a7e8d531b5633c46ec52 (patch)
tree	f20c1d7e42bd1117c86c17b620cc90ff7f2f0f7f
parent	2aaf5a73dac9f1dc137fba1e5f8536ef9f67ed89 (diff)
sw: less vcl text layout calls in SwFont::GetTextBreak()
Number of GenericSalLayout::LayoutText() calls during "dt<F3>" in Writer: 105
-> 89.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2a73c9e04ba9379c0561a7e8d531b5633c46ec52
Comment 2 Buovjaga 2020-06-18 14:50:52 UTC
(In reply to Telesto from comment #1)
> Bisected to
> author	Miklos Vajna <vmiklos@collabora.co.uk>	2018-09-07 10:43:10 +0200
> committer	Miklos Vajna <vmiklos@collabora.co.uk>	2018-09-07 16:02:49 +0200
> commit	2a73c9e04ba9379c0561a7e8d531b5633c46ec52 (patch)
> tree	f20c1d7e42bd1117c86c17b620cc90ff7f2f0f7f
> parent	2aaf5a73dac9f1dc137fba1e5f8536ef9f67ed89 (diff)
> sw: less vcl text layout calls in SwFont::GetTextBreak()
> Number of GenericSalLayout::LayoutText() calls during "dt<F3>" in Writer: 105
> -> 89.
> 
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=2a73c9e04ba9379c0561a7e8d531b5633c46ec52

Here we see again a cache-related tweak. Not sure, if bug
Comment 3 dante19031999 2020-06-18 15:00:04 UTC

*** This bug has been marked as a duplicate of bug 133652 ***
Comment 4 Buovjaga 2020-06-18 15:02:08 UTC
Discussed this briefly in #libreoffice-dev and consensus was to close as notabug