Download it now!
Bug 133658 - Trying to replace 1 highlighted (selected) character during autosave results in infinite loop
Summary: Trying to replace 1 highlighted (selected) character during autosave results ...
Status: NEEDINFO
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoSave-AutoRecovery-Backup
  Show dependency treegraph
 
Reported: 2020-06-04 06:29 UTC by Peter Protsenco
Modified: 2020-10-16 15:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Protsenco 2020-06-04 06:29:48 UTC
Description:
Libre Offie Writer Версия: 6.4.4.2 (x64)
ID сборки: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
Потоков ЦП: 4; ОС: Windows 10.0 Build 18363; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: CL
I was simply replacing one selected character in text on a regular page of my .docx document when autosave occured just exactly the moment I entered a replacement character from keyboard. The next moment I found myself unable to type or undo or make any other correction because the autosave progress bar in status panel was restarting infinitely, saving and saving, until after 3 minutes I terminated all LibreOffice processes via Task Manager.
As for what happened to my document. I lost all changes and 10 minutes of hard work, all the calculated values for my report. On next attempt to open the document it was found defective and restoration procedure started (oh, please, remove this useless feature) upon "successful" restoration not only the changes were lost, but the picture (plot) I inserted earlier overlaped with text, even thoug I made specific precautions setting parameters "обтекание" and "привязка" for which I do not know exact originals in EN version.

Steps to Reproduce:
1. Set autosave time
2. Select a character in your .docx document
3. Type over selected character in the exact moment of autosave

Actual Results:
Does not save, infinite loop, loss of control over application

Expected Results:
I expected to continue editing


Reproducible: Didn't try


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: ru
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes
Версия: 6.4.4.2 (x64)
ID сборки: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
Потоков ЦП: 4; ОС: Windows 10.0 Build 18363; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: CL
Comment 1 Buovjaga 2020-10-16 15:06:24 UTC
Went to Tools - Options - Load/Save - General.
Changed autorecovery saving frequency to 1 minute.
Used the dt, F3 autotext and copied and pasted many times to get a document with 3600 pages, saved.
Pressed Insert key and started typing in overwrite mode for a couple of minutes.

No infinite loop observed. Tried both with an ODT and a DOCX.

Peter: are you able to reproduce the problem reliably?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.

Version: 7.1.0.0.alpha0+ (x64)
Build ID: df74aef7159d7155addf78cfc4d139485945d794
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: default; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded