Bug 133687 - FILEOPEN PPTX: text box shifts over other text box (and adopts its style)
Summary: FILEOPEN PPTX: text box shifts over other text box (and adopts its style)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Gülşah Köse
URL:
Whiteboard: target:7.1.0 target:7.0.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2020-06-04 22:58 UTC by Gerald Pfeifer
Modified: 2020-08-05 08:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample slide (PPTX) (590.73 KB, application/vnd.ms-powerpoint)
2020-06-04 22:58 UTC, Gerald Pfeifer
Details
Side by side of the slide in Office 365 and LibreOffice, trouble area being highlighted (29.58 KB, image/png)
2020-06-04 23:00 UTC, Gerald Pfeifer
Details
How it looks in LibreOffice (23.22 KB, image/png)
2020-06-04 23:00 UTC, Gerald Pfeifer
Details
How it looks in Office 365 (23.82 KB, image/png)
2020-06-04 23:01 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2020-06-04 22:58:37 UTC
Created attachment 161624 [details]
Sample slide (PPTX)

When opening the attached slide in LibreOffice the second subtitle is
shifted on top of the first subtitle and it adopts its style (font color
and size).
Comment 1 Gerald Pfeifer 2020-06-04 23:00:00 UTC
Created attachment 161625 [details]
Side by side of the slide in Office 365 and LibreOffice, trouble area being highlighted
Comment 2 Gerald Pfeifer 2020-06-04 23:00:51 UTC
Created attachment 161626 [details]
How it looks in LibreOffice
Comment 3 Gerald Pfeifer 2020-06-04 23:01:30 UTC
Created attachment 161627 [details]
How it looks in Office 365
Comment 4 Xisco Faulí 2020-06-22 13:45:13 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=cc6ae367280d205a88c6f907b20b84613221ca52

author	Matúš Kukan <matus.kukan@collabora.com>	2014-08-07 13:25:51 +0200
committer	Matúš Kukan <matus.kukan@collabora.com>	2014-08-07 21:05:07 +0200
commit	cc6ae367280d205a88c6f907b20b84613221ca52 (patch)
tree	a803f213ac28a7b10cb150388094b546d13821ed
parent	f4677f58a26d1183af5c91470be0e4f782e6cbeb (diff)
bnc#821916: Better algorithm to find placeholder shape.

Bisected with: bibisect-44max
Comment 5 Xisco Faulí 2020-06-22 13:48:05 UTC
Hello Serge,
Since you fixed bug 119187 which looks similar to this issue, I thought you might be interested in this one as well
Comment 6 Commit Notification 2020-08-03 21:00:09 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e0018be102edd6e376e0622e0a9384176d2f119c

tdf#133687 Fix the placeholders priority order.

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2020-08-04 07:55:26 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 58937aa4a50ecd681382f03331340da4c843b01e
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Gülşah Köse, thanks for fixing this issue!
Comment 8 Commit Notification 2020-08-05 08:24:30 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/802fa332fc05a119c525f20a46ac3aaea7900602

tdf#133687 Fix the placeholders priority order.

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.