Bug 133700 - Autofilter drop down opens slowly
Summary: Autofilter drop down opens slowly
Status: RESOLVED DUPLICATE of bug 128078
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2020-06-05 13:19 UTC by Telesto
Modified: 2020-06-09 15:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Bibisect log (2.91 KB, text/plain)
2020-06-05 13:20 UTC, Telesto
Details
Example file (8.27 MB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-06-05 13:21 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-05 13:19:58 UTC
Description:
Autofilter drop down opens slowly

Steps to Reproduce:
1. Open the attached file
2. Click on the drop down button in cell A1

Actual Results:
18 seconds until open

Expected Results:
9 seconds until open


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 191288d6a7fb52b31038a21c4e71ee57ffa3bacd
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-06-05 13:20:58 UTC
Created attachment 161650 [details]
Bibisect log

Bisected to
author	Caolán McNamara <caolanm@redhat.com>	2017-07-14 14:22:06 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2017-07-14 18:11:03 +0200
commit	94c7a401583200cf5982594b1b043ad1a5e3cd38 (patch)
tree	993b6717312394349d547e271b8e2e8811194b12
parent	6b6b81cae861a1e6463360d1b320c0d3e24de111 (diff)
Resolves: tdf#99071 tree view shows odd text widths when > 100 lines
reverts

commit 62ea355b2679073b8ee326df5793231996136da9
Date:   Thu Dec 12 09:55:35 2013 +0100

    fdo#72125: GetTextWidth() can get very expensive.

    Let's just count an approximate width using a cached value when we have too
    many entries.

The expert dialog got fixed by not populating it with all options on load
and instead by incremental disclosure as the users searches/expands it so
this optimization effort isn't needed

in the meantime there was another problem the above papered over with

commit b4bbb5e5d7b31caad2fbcc00382ad27df3c81001
Date:   Sun May 17 22:56:46 2015 +0900

refactor how font, fg. and bg. are applied in widgets/controls

which was fixed (hopefully) in the previous commit
Comment 3 Telesto 2020-06-05 13:21:45 UTC
Created attachment 161651 [details]
Example file
Comment 4 Xisco Faulí 2020-06-09 12:11:28 UTC

*** This bug has been marked as a duplicate of bug 109158 ***
Comment 5 tommy27 2020-06-09 15:17:17 UTC
so is this basically the same issue with the same code root but with effect on a different UI part? (autofilter vs autocorrect)
Comment 6 V Stuart Foote 2020-06-09 15:38:33 UTC
Yes, populating SvTreeLisBox is done in multiple UI elements--with performance impact of calculating text widths & heights for each list item.

So, lets dupe to bug 128079 for the issues still held over from the not fully resolved bug 109158.

*** This bug has been marked as a duplicate of bug 128078 ***