Bug 133723 - Writer's defaults are not the same as with the Default template
Summary: Writer's defaults are not the same as with the Default template
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-06-06 10:06 UTC by andreas_k
Modified: 2020-09-25 07:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
left is the default template file, right when you open writer with an empty file (65.78 KB, image/png)
2020-06-06 10:09 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2020-06-06 10:06:34 UTC
In the template manager there is an Default Template File which is located in core/extras/source/templates/styles/Default/ why don't use writer this default template file?
Comment 1 andreas_k 2020-06-06 10:09:12 UTC
Created attachment 161676 [details]
left is the default template file, right when you open writer with an empty file

It's nearly the same but I cleaned up the layer and this is not the same when I open writer so I found out that writer didn't use the default template file.
Comment 2 Heiko Tietze 2020-06-08 08:48:50 UTC Comment hidden (off-topic)
Comment 3 Heiko Tietze 2020-09-21 13:34:52 UTC
Writer's defaults are hard-coded. If you load any template it will override those. So it's working as designed and the only question is whether we should rename the template because Default might confuse users.
Comment 4 andreas_k 2020-09-21 21:14:30 UTC
(In reply to Heiko Tietze from comment #3)
> Writer's defaults are hard-coded. If you load any template it will override
> those. So it's working as designed and the only question is whether we
> should rename the template because Default might confuse users.

I'm not a fan of hard-coded as in addition the default writer template is exact what was done hard-coded. So we can remove hard-coded presets with the template or close the bug.
Comment 5 Thomas Lendo 2020-09-22 16:26:43 UTC
If it's not a real default in the program, this so-called template should be renamed.
Comment 6 Heiko Tietze 2020-09-25 07:29:30 UTC
We discussed the topic in the design meeting and decided to resolve as WF.

While the issues was accepted and using the template as default there are also many blockers. First of all we have many variables that not all are defined in a template (all attributes of all paragraph/character/page/frame/table... styles). It's also not recommended to trust in a template as this might be deleted or not available for other reasons (for example not compiled/installed via switch). And last but least we run unit tests to ensure pixel-perfect documents after each included patch that also need to run with constant data.
Renaming to Blank, Plain or whatever would be possible be also not solve the issue. Users cannot rename, delete, modify this templates because it's not placed in the user space. And removing everything is also not desirable.
So what we have to do is to add more and better templates (and maybe at the user space). If this has been done we could delete "Default".