Bug 133786 - enable Writer in its 'Web' view mode to display page numbering of its 'Normal' view
Summary: enable Writer in its 'Web' view mode to display page numbering of its 'Normal...
Status: RESOLVED DUPLICATE of bug 67698
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-06-08 09:53 UTC by tpypta
Modified: 2021-03-17 22:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Normal view page indicator (4.13 KB, image/jpeg)
2020-06-08 09:56 UTC, tpypta
Details
Web view page indicator (same document) (4.10 KB, image/jpeg)
2020-06-08 09:56 UTC, tpypta
Details
Demo of a typical usage case of "Web" mode in the field of Humanities (629.96 KB, image/jpeg)
2020-06-09 07:04 UTC, tpypta
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tpypta 2020-06-08 09:53:23 UTC
Description:
Hi LO devs! I've saw a minor bug in LibreOffice Writer Version: 6.3.6.2 (x64)(Still)on Windows 10. It seems that the page number indicator on the bottom lest always says "Page 1 of 1" even though in "Normal" view I'm on page 44. Sometimes, between page 20 and 26 the bottom indicator says "Page 1 of 2" / "Page 2 of 2". If this is the expected behaviour then the Page indicator is quite useless in "Web view". Usage case: I usually take advantage of "Web view" when I have a PDF opened on the left, and on the right - a sized LO Writer to take notes, quotations, etc. It would be very useful if the indicator displays the "Normal view" page number in order to not lose track on the targeted volume of the current chapter.

Steps to Reproduce:
1. Open a document with a couple of pages.
2. View -> Web to go to "Web view".
3. Look at page number indicator at the bottom left.

Actual Results:
Page indicator always says "Page 1 of 1", and somethimes arround actual page 20 - "Page 1 of 2".

Expected Results:
The expected result isto display the "Normal view" page number in "Web view".


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.6.2 (x64)
Build ID: 2196df99b074d8a661f4036fca8fa0cbfa33a497
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: bg-BG (bg_BG); UI-Language: en-US
Calc: CL
Comment 1 tpypta 2020-06-08 09:56:20 UTC
Created attachment 161754 [details]
Normal view page indicator
Comment 2 tpypta 2020-06-08 09:56:54 UTC
Created attachment 161755 [details]
Web view page indicator (same document)
Comment 3 V Stuart Foote 2020-06-08 14:38:24 UTC
Always been that way. And Writer Web view can not paginate as Writer print/normal layout will. HTML has no concept of a page as the document will fill the available buffer--not by screens, not by physical page. 

Page 1 of 1 is exactly correct. It will not advance to page 2 until the content of the document exceeds the 'page size' of the browser model used--20 - 30 print pages sound about right. 

There is no css/html5 controlling this archaic LibreOffice mode. Not clear it would be worth the dev effort to implement pagination of the HTML4 content the Web Writer can view/markup.
Comment 4 Buovjaga 2020-06-08 14:39:52 UTC
Stuart is right. The concept of pagination does not apply to web view.
Comment 5 tpypta 2020-06-08 15:13:28 UTC
Well... The thing is that this mode is super useful, since it declutters the whole workspace from margins, paginations, etc. and it even auto-reflows to match the new Writer window width. That's why many scholars like me still use this 'archaic' functionality, since it allows one to allocate more screen "real estate" to the opened source (PDF/jpeg) and write in an about 20% width LibreOffice Writer. Later on, when the notes are done, Writer goes full width in "Normal mode". This expected behaviour of the page indicator is just like that in Word 365, where the switch between "Normal" and "Web" layout is even easier. "Web" layout doesn't need pagination like in "Normal", since it's perfect just as it is - an "endless" whitespace to throw notes and quotations while reading sources. However, the page indicator needs to show the same number as in "Normal", otherwise this indicator in "Web" is useless, since it shows... er, what? That's why I reported it as a minor bug, since just the output of the indicator shall be the same as it is in "Normal", and this really is the expected behaviour). However, if the indicator requires a pagination to be implemented in "Web", then it really isn't going to be worth the dev time, since I can always jump tp "Normal" to see on which page I am. But, if the indicator can be fixed by easily forcing it to display "Normal view" page number" in "Web view", then it shall be done. Probably many scholars (expecially in Humanities)are waiting for ages for a fix of this minor inconveniece.
Comment 6 V Stuart Foote 2020-06-08 16:16:33 UTC
(In reply to Buovjaga from comment #4)
> Stuart is right. The concept of pagination does not apply to web view.

Actually read the use case again closely. The OP wants to use Writer in Web view for concise note taking--not for generating HTML.  Truth is that with Writer in its Web view--the canvas is striped of its 'page' motif, but document paragraphs continue to respond to their applied styles.

As the 'Web' viewing mode really is just another VCL rendering mode--akin to the Print preview-- it has the "potential" to reflect the pagination as assigned to Paragraphs in normal view, as modified by Page style and any manual Page breaks.

Not sure how much of an effort it would be--and one could make the case for calling this mode something other than/in addition to 'Web' view.
Comment 7 Michael Stahl (allotropia) 2020-06-08 16:27:05 UTC
in Writer/Web, there is by design only 1 page. if it says there are 2 pages, that would be a bug.

not showing similar page numbers to the paginated layout is a feature, because the layout isn't paginated.

=> NOTABUG
Comment 8 V Stuart Foote 2020-06-08 16:34:35 UTC
@Michael S. but this is not Writer/Web, this is for Writer!  And, no claim it is a bug, rather an enhancement for Writer in its 'Web' view mode.

So, => WF

But, could the paragraph structure be parsed in this concise 'Web' view mode to respond to the pagination received as would apply fully rendered in Writer's 'Normal' mode?  If need be call it something else 'Notetaking' mode.
Comment 9 Mike Kaganski 2020-06-08 16:36:15 UTC
(In reply to Michael Stahl (CIB) from comment #7)
> in Writer/Web, there is by design only 1 page. if it says there are 2 pages,
> that would be a bug.

In fact, web view is implemented as 10-meter long pages. Thus it will show Page 2 after that limit, and so on.

I would simply drop the page indicator from that view, and be done with that.
Comment 10 V Stuart Foote 2020-06-08 16:52:49 UTC
(In reply to V Stuart Foote from comment #8)
> ...
> But, could the paragraph structure be parsed in this concise 'Web' view mode
> to respond to the pagination received as would apply fully rendered in
> Writer's 'Normal' mode?  If need be call it something else 'Notetaking' mode.

Even dress it up a bit and call it a new MUFFIN mode. 

Personally I'd never thought to use Writer in 'Web' view as I didn't get the use case--typically I'd save-as and open and work in Writer/Web as HTML. 

But playing with this a bit it is kind of handy for non-WYSIWYG layout--but accepting Paragraph, Frame, Section, Draw objects--just on a different canvas. More like OneNote or Evernote.
Comment 11 tpypta 2020-06-09 07:04:03 UTC
Created attachment 161785 [details]
Demo of a typical usage case of "Web" mode in the field of Humanities

The program on the left might be anything - web page, picture, PDF, epub, Adobe Digital Editions, EBSCO resource, JSTOR.... etc. In the Writer window the scholar throws research notes and citations. After he is done with collecting sources, the scholar switches to "Normal" view and starts writing the body of the text, the analysis.... etc.
Comment 12 V Stuart Foote 2021-03-17 22:09:53 UTC

*** This bug has been marked as a duplicate of bug 67698 ***