Download it now!
Bug 133802 - Bullet/number added to the beginning of a heading when exporting to Microsoft Word .docx
Summary: Bullet/number added to the beginning of a heading when exporting to Microsoft...
Status: RESOLVED DUPLICATE of bug 107683
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Styles-Heading DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2020-06-08 18:35 UTC by am_dxer
Modified: 2020-06-16 10:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description am_dxer 2020-06-08 18:35:36 UTC
Description:
When exporting to a Microsoft Word document, there is an extra format character inserted at the beginning of a heading. Depending on how you view the document, it is a heading or a number.

Steps to Reproduce:
1. Open Libreoffice Writer and write some text. Press Control+1 to make it a heading level 1.
2. Save two coppies of the document, one as DOCX and the other as ODT.
3. If you open both documents in LibreOffice Writer and select preview in web browser, there is a 1. at the beginning of each heading you insert which shouldn't be there in the word dOCX. This is not visible when previewing the ODT.
4. If you open the docx in word, there is a bullet that is interpreted before the line. You cannot see this visually. I noticed it because I use a screen reader. Even though the bullet is invisible, the screen reader reads the bullet semantics  from the document for some reason. You can notice it visually by moving the cursor to the left of the first physical character in the line. This only works in Microsoft Word.

Actual Results:
These bits of evidence make me think that some extraneous formatting is being exported when saving as docx. 

Expected Results:
NO bullet or number when exporting.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.4.4.2
Build ID: 1:6.4.4-1
CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 am_dxer 2020-06-08 18:40:38 UTC
For 3 in the steps to reproduce. You need to close the word DOCX and reopen it before previewing it in the web browser to notice this bug. Also, I used Firefox on Linux as well as LibreOffice on Linux. Word was used on Windows 10 and was major version 2016 and minor release 2003.
Comment 2 am_dxer 2020-06-08 19:56:08 UTC
In my bug description, I said "Depending on how you view the document, it is a heading or a number". I meant to say "Depending on how you view the document, it is a bullet or a number".
Comment 3 Dieter 2020-06-10 12:50:36 UTC
I confirm it with

Version: 7.0.0.0.beta1 (x64)
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

I think it's related to bug 107683 or perhaps a duplicate of it.
Comment 4 NISZ LibreOffice Team 2020-06-16 10:44:05 UTC
(In reply to Dieter from comment #3)
> 
> I think it's related to bug 107683 or perhaps a duplicate of it.

I'm fairly sure this is a duplicate of that one.

*** This bug has been marked as a duplicate of bug 107683 ***