Bug 133872 - Crash in: sclo.dll
Summary: Crash in: sclo.dll
Status: RESOLVED DUPLICATE of bug 132783
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-10 18:06 UTC by James Beard
Modified: 2020-06-15 13:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["sclo.dll"]


Attachments
SpreadSheet with minimum Data to trigger the bug (8.60 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-06-14 02:38 UTC, Christian Blanchart
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Beard 2020-06-10 18:06:29 UTC
This bug was filed from the crash reporting server and is br-937d8763-d05a-477d-a965-a2ad0e3f7695.
=========================================
Repeatable crash when doing a search in Calc with a really huge file, two tabs, originally exported as CSV from Outlook and a cell phone.  Enter any search string and crash is instantaneous on clicking the up or down carat (arrow).  Re-downloaded LO 6.3.6.2 and ran Repair, no change.   I suspect that this is a stack space overflow.
Comment 1 m.a.riosv 2020-06-10 20:05:40 UTC
Have you tried with a clean profile, Menu/Help/Restart in Safe Mode.
Comment 2 James Beard 2020-06-11 04:51:08 UTC
(In reply to m.a.riosv from comment #1)
> Have you tried with a clean profile, Menu/Help/Restart in Safe Mode.

I just tried reset to safe mode, with "Reset to Factory Settings" checked with both options "Reset settings and user interface modifications" and "Reset entire user profile".  No change; will crash instantly on any search.
Comment 3 QA Administrators 2020-06-12 03:47:35 UTC Comment hidden (obsolete)
Comment 4 James Beard 2020-06-12 08:19:11 UTC
I've used this ODS file, with searches, for about two years.  Never had a problem until I upgraded to LO 6.3.6.2 x64 a few days ago.  The ODS file has two tabs.  The crash happens on both tabs.  Tab 1 has 205 rows, tab 2 has 910 rows.  Both tabs have 92 columns (last column label is CN).  Most cells have data; some are empty.  A few cells have a lot of data, up to about 500 characters.

The file is a combination of two CSV dumps of my contact list when I had a cell phone die on my in 2018.  If absolutely necessary, I can generate a new file with random data and try to duplicate the problem.
Comment 5 E Kimbrough 2020-06-12 08:57:14 UTC
I'm having the same bug. Calc Version 6.3.6.2 x64 also, french localisation.
In a .csv file, UT-8, french language, ; as separator , and all column forced to text format on opening.

Any search from the bottom research box cause the crash.

The csv file is generated as an export from a SQLplus dabatase.

It has 650 lines, 250 columns.
Comment 6 Christian Blanchart 2020-06-14 02:38:17 UTC
Created attachment 161971 [details]
SpreadSheet with minimum Data to trigger the bug

To trigger the 'Search Bug' from the attached SpreadSheet, just search for e.a. 100 and it will hangs up at once.

Here after, as I don't know the actual name for it, I'll assign the name 'active Data zone' the zone between Cell A1 and the Cell we could get with <Ctrl><End> keyboard action. e.a. Here between A1 and AMH11

So .... A way to get around that crash (until it'll be corrected):
==>  Click onto any cell into a column outside the 'active Data zone' ( e.a. here in column AMI or AMJ ) in any row .... that action will lead to successful search result again.
REM: That way to overcome the issue will have to be redo any time you'll reload the concerned CALC File.
NB: I don't know if that momentary way to overcome the issue is artificial or not. Is it going to reappear in the future and under other circumstances ?

Hope this could help meanwhile,
Christian
Comment 7 James Beard 2020-06-14 04:23:04 UTC
I tried the workaround in Comment 6 that was suggested by chr.blanchart@gmail.com and it did work for me.  After a first search that starts from a column past the highest numbered column that contains data, the search function works without a crash again.
Comment 8 Xisco Faulí 2020-06-15 13:53:10 UTC
Thanks for reporting this issue.
This is a duplicate of bug 132783 and it's fixed in LibreOffice 6.4.4

*** This bug has been marked as a duplicate of bug 132783 ***