Download it now!
Bug 133914 - Crash swlo!BigPtrArray::Index2Block
Summary: Crash swlo!BigPtrArray::Index2Block
Status: RESOLVED DUPLICATE of bug 135167
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Crash-BigPtrArray
  Show dependency treegraph
 
Reported: 2020-06-11 20:52 UTC by Telesto
Modified: 2020-07-27 11:14 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (8.11 KB, text/plain)
2020-07-27 10:53 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-11 20:52:38 UTC
Description:
Crash swlo!BigPtrArray::Index2Block

Steps to Reproduce:
1. https://bz.apache.org/ooo/attachment.cgi?id=46676
https://bz.apache.org/ooo/show_bug.cgi?id=79410

2. CTRL+A
3. CTRL+C
4. CTRL+V
5. CTRL+Z

Actual Results:
Crash

Expected Results:
no Crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: a201ab6f47c2d5a7ba4c5f998b0aa231cae82010
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 MM 2020-06-12 19:34:15 UTC
Unconfirmed on mint 19.3 x64 with Version: 7.1.0.0.alpha0+
Build ID: 20ba8d8d9f4fcf7d5826fcb3366a9bff0d6a8ca1
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-06-10_07:16:41
Calc: threaded

Windows only ?
Comment 2 Telesto 2020-06-12 19:40:19 UTC
Me being sloppy
1. https://bz.apache.org/ooo/attachment.cgi?id=46676
https://bz.apache.org/ooo/show_bug.cgi?id=79410

2. CTRL+A
3. CTRL+C
4. CTRL+N <- Missed this one
4. CTRL+V
5. CTRL+Z
Comment 3 MM 2020-06-13 17:10:42 UTC
Re-tested:

Confirmed on mint 19.3 x64 with Version: 7.1.0.0.alpha0+
Build ID: 20ba8d8d9f4fcf7d5826fcb3366a9bff0d6a8ca1
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-06-10_07:16:41
Calc: threaded
Comment 4 Telesto 2020-06-13 18:03:37 UTC
Also crashing
6.4
6.3
6.1
4.4.7.2
4.0
3.3.0
Comment 5 Julien Nabet 2020-07-27 10:53:54 UTC
Created attachment 163607 [details]
bt with debug symbols

Here's a bt retrived on pc Debian x86-64 with master sources updated today.
Comment 6 Telesto 2020-07-27 11:14:34 UTC

*** This bug has been marked as a duplicate of bug 135167 ***