Bug 134212 - Adding fonts for special features
Summary: Adding fonts for special features
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts-Bundled
  Show dependency treegraph
 
Reported: 2020-06-22 00:14 UTC by dante19031999
Modified: 2020-06-30 22:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dante19031999 2020-06-22 00:14:43 UTC
Description:
For some near future improvements of LO math are requiered two fonts:
Diplomata //mathbb
Rouge Script //scrip
Both fonts are open fonts. Can be downloaded from google fonts. Should be in:/libreoffice/instdir/share/fonts/openType

Actual Results:
 

Expected Results:
 


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 V Stuart Foote 2020-06-22 01:08:09 UTC
bug 101174 is open to allow use of font other than project provided OpenSymbol. At that point pretty much any on system font with good Unicode coverage and reasonable metrics would be usable.

Adding non-usable fonts at this point is pointless. General consensus has been to reduce the packaged fonts to just what is needed for correct formatting of templates, interoperability and special features (like the sm Formula Editor).

Other fonts are decision of user and as supported by their os/DE.
Comment 2 dante19031999 2020-06-22 03:25:42 UTC
I already know that fonts have to be kept to a minimum.
I've already seen LO fonts an none of them can do what those two can do.
As I said, they are requiered for adding mathbb and script functions to math.
V Stuart Foote says it: correct formatting of templates, interoperability and special features (like the sm Formula Editor).
Comment 3 dante19031999 2020-06-22 03:26:40 UTC
This is requiered as a preparation step for the implementation of those.
Comment 4 dante19031999 2020-06-22 03:32:57 UTC
For example they are needed for bug 49990.
Comment 5 V Stuart Foote 2020-06-22 12:45:33 UTC
No, users with an interest in expanded node logic for additional sm Elements catalog will already have appropriate fonts "on system".

Implementers of such additional nodes would be responsible for adding to the default OpenSymbol (opens___.ttf), or to its replacement font should one be selected.

DejaVu or STIX 2 have been my thought.
Comment 6 dante19031999 2020-06-22 13:15:30 UTC
(In reply to V Stuart Foote from comment #5)
> No, users with an interest in expanded node logic for additional sm Elements
> catalog will already have appropriate fonts "on system".
> 
> Implementers of such additional nodes would be responsible for adding to the
> default OpenSymbol (opens___.ttf), or to its replacement font should one be
> selected.
> 
> DejaVu or STIX 2 have been my thought.

I don't really mind whose fonts are. I just need a double stroke one and a script one usable for mathematics. After that the user is free to use whatever he wants. For example I use Fine Blackboard as double stroke font, but it costs 50,000€ for large agencies. DejaVu is verry common on linux systems. The STIX 2 are nice, but do not cover this. If it's OK I can upload them to gerrit.

I'm fragmentating the math improvements into small parts because they said me it would be better to only solve one bug / enancement per patch. But takes a lot of time.
Comment 7 dante19031999 2020-06-22 13:24:14 UTC
The STIC 2 math could replace opensymbol, I would not have to deal with this mess while coding: bug 134214.