Download it now!
Bug 134280 - Can set Epsilon Level 4 on Coin MP Solver
Summary: Can set Epsilon Level 4 on Coin MP Solver
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-24 12:33 UTC by sawakaze
Modified: 2020-06-26 13:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen capture: set epsilon level 4 on CoinMP Solver. (35.45 KB, image/png)
2020-06-24 12:35 UTC, sawakaze
Details
screenshot with gtk3 rendering (38.74 KB, image/png)
2020-06-25 10:27 UTC, Julien Nabet
Details
Screenshot with COINMP (33.43 KB, image/png)
2020-06-25 19:41 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sawakaze 2020-06-24 12:33:09 UTC
Description:
User can set Epsilon Level 4 Coin MP solver.


Steps to Reproduce:
1. Open Tool > Solver
2. set Target Cell and Optimize result to and By Changing  cells and Limiting Condition.

3. set Options
-> Open Oprions Window 
4. select CoinMP Linear Solver
5. set "Epsilon level(0-3)" -> 4.
(Screen capture)
6. Press OK on Options Window
7. press Solve


Actual Results:
Run Solver

Expected Results:
Not run Solver because the epsilon level is invalid.



Reproducible: Always


User Profile Reset: No



Additional Info:
If solver engine is "libreoffice linear solver" , not run Solver and launch error window "the epsilon level is invalid.".
Comment 1 sawakaze 2020-06-24 12:35:22 UTC
Created attachment 162369 [details]
Screen capture: set epsilon level 4 on CoinMP Solver.
Comment 2 Julien Nabet 2020-06-24 13:48:27 UTC
On Win 10 with master sources updated today, I could reproduce this.
Comment 3 Julien Nabet 2020-06-24 16:45:00 UTC
I could also reproduce this on pc Debian x86-64 with master sources updated today (gen or gtk3 rendering).
I see no specific messages on terminal and don't understand why some checkboxes may appear not all.

Caolán: thought you might be interested in this one.
Comment 4 Caolán McNamara 2020-06-24 18:55:02 UTC
presumably easy to make that work better
Comment 5 Commit Notification 2020-06-24 19:58:05 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/efa19c9a5004699d844d108e2bf0dce845d48959

tdf#134280 set legal range for Epsilon level

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-06-24 19:58:14 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/56b6013c9588f870ddc02c82ae1bbcbf856cb8c5

tdf#134280 set legal range for Epsilon level

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Julien Nabet 2020-06-25 10:27:40 UTC
Created attachment 162395 [details]
screenshot with gtk3 rendering

Sorry, I still reproduce this with master sources updated today.
Comment 8 Julien Nabet 2020-06-25 10:28:57 UTC
Same thing with gen and kf5 renderings.
Comment 9 Caolán McNamara 2020-06-25 18:38:28 UTC
The original report was about the "Epsilon Level" and the "Coin MP" solver. That screenshot lists different options and a "DEPS..." solver I don't seen to have by default (--enable-ext-nlpsolver maybe?) Does the "Epsilon Level" behave correctly for the "Coin MP" case and its matter of adding limits for some other options too.
Comment 10 Julien Nabet 2020-06-25 19:41:03 UTC
Created attachment 162414 [details]
Screenshot with COINMP

Here's a screenshot with COINMP.
May the number of entries vary?
Comment 11 Caolán McNamara 2020-06-25 19:55:00 UTC
on re-reading comment #3 I think we're possibly talking at cross-purposes
"... don't understand why some checkboxes may appear not all".
Those options without a checkbox are meant to be like that, if you double click them (or use the edit button which becomes sensitive when you click on it) then you get another dialog which lets you set the value displayed there, that's how to do step 5. That may be the confusion.

And the problem I fixed was that you could use that dialog to set any value for the "Epsilon Level" not just the 0-3 range it claims are legal in the edit dialog (and the entry text) with my change in place that subdialog spinbutton is max-ed to 3.

(and https://gerrit.libreoffice.org/c/core/+/97185 to put limits for the other options shown for the "DEPS..." which don't have a checkbox but activating the row presents similar dialogs)
Comment 12 Julien Nabet 2020-06-26 06:32:25 UTC
(In reply to Caolán McNamara from comment #11)
> on re-reading comment #3 I think we're possibly talking at cross-purposes
> "... don't understand why some checkboxes may appear not all".
> Those options without a checkbox are meant to be like that, if you double
> click them (or use the edit button which becomes sensitive when you click on
> it) then you get another dialog which lets you set the value displayed
> there, that's how to do step 5. That may be the confusion.
> 
> ...

You're right, I had read a little too quickly the bugreport.
When I gave it a try, I saw this first and didn't re read the report.
For the rest, I hadn't thought about a double click to change the value.
I'm not fan of this mechanism and would have prefered a spinbutton which is more explicit.

Anyway, I'll put this back to FIXED since the initial bugreport is indeed fixed.
Sorry for the noise!
Comment 13 Commit Notification 2020-06-26 08:57:15 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/efe623fdc2abd3f1bbd09faa70ae1b7f00edb5b5

Related: tdf#134280 set max limits for solver options that show max values

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-06-26 13:59:46 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/c7986b21e9b0a9208ab5bb665d25a5385798207b

Related: tdf#134280 set max limits for solver options that show max values

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.