Bug 134282 - EDITING Undoing heading level change does not restore outline level
Summary: EDITING Undoing heading level change does not restore outline level
Status: RESOLVED DUPLICATE of bug 69811
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Undo-Redo
  Show dependency treegraph
 
Reported: 2020-06-24 13:23 UTC by NISZ LibreOffice Team
Modified: 2020-06-25 09:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Writer (9.21 KB, application/vnd.oasis.opendocument.text)
2020-06-24 13:23 UTC, NISZ LibreOffice Team
Details
The file before changes (18.65 KB, image/png)
2020-06-24 13:23 UTC, NISZ LibreOffice Team
Details
The file after changes (20.32 KB, image/png)
2020-06-24 13:24 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-06-24 13:23:20 UTC
Created attachment 162370 [details]
Example file from Writer

Attached example document contains two paragraphs formatted with Heading 2 style. This makes them numbered as 1.1 and 1.2.
Changing the first paragraphs style to Heading 1 changes its numbering to 1, while the other paragraphs numbering to 1.1.
Undoing this change does not restore previous numbering, the 1 and 1.1 stay, despite the first paragraphs style is restored as Heading 2.

Steps to reproduce:
    1. Open attached document
    2. Change the first paragraphs style to Heading 1
    3. Undo

Actual results:
First paragraphs numbering is not restored to 1.1

Expected results:
First paragraphs numbering should be restored to 1.1, second paragraphs to 1.2

LibreOffice details:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 642fc41cd7d080384658e10b30bb9d3b38a2cbd9
CPU szálak: 4; OS: Windows 6.3 Build 9600; Felületmegjelenítés: alapértelmezett; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL

Also happens in:
Verzió: 6.0.0.3
Build az.: 64a0f66915f38c6217de274f0aa8e15618924765
CPU szálak: 4; OS: Windows 6.3; Felületmegjelenítés: alapértelmezett; 
Területi beállítások: hu-HU (hu_HU); Calc: CL

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: hu-HU (hu_HU)

Verzió: 4.0.0.3 (Build az.: 7545bee9c2a0782548772a21bc84a9dcc583b89)

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 1 NISZ LibreOffice Team 2020-06-24 13:23:55 UTC
Created attachment 162371 [details]
The file before changes
Comment 2 NISZ LibreOffice Team 2020-06-24 13:24:11 UTC
Created attachment 162372 [details]
The file after changes
Comment 3 Timur 2020-06-25 09:15:01 UTC
Repro.
Version: 7.1.0.0.alpha0+ (x64)
Build ID: aadcd6f90916bd2b9734ae793141d0c77cc5b46c
CPU threads: 2; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win

Looks like a duplicate of bug 69811 which is more general: restored number is from heading 1. 
But even that one didn't notice it's just until next reload, when it's fine.

*** This bug has been marked as a duplicate of bug 69811 ***