Download it now!
Bug 134351 - Wrong Auto Filter Result if all the records are selected
Summary: Wrong Auto Filter Result if all the records are selected
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: high trivial
Assignee: Xisco Faulí
URL:
Whiteboard: target:7.1.0 target:7.0.3 target:6.4....
Keywords: bibisected, bisected, regression
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2020-06-28 04:09 UTC by Kevin Suo
Modified: 2020-10-06 13:56 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2020-06-28 04:09:54 UTC
This is a minor bug.

Steps to Reproduce:

1. Type in the following in A1 and A2:
a
1

2. Set auto filter.

3. Click on the dropdown list in A1 and type in "1" in the input box, then click OK.

Current Result:
The filtered result is NONE.

Expected Result:
The filtered result should either be 1, or Calc just refuses to show the filter, as there is only one row.
Comment 1 Kevin Suo 2020-06-28 04:11:12 UTC
Regression caused by:
author	scito <info@scito.ch>	2020-04-03 16:13:42 +0200
committer	Serge Krot (CIB) <Serge.Krot@cib.de>	2020-04-29 17:21:25 +0200
commit	e9c04fdc6d91a152c9197bda3b07316bed1dc4f3
tdf#130770 apply autofilter to data regardless of autofilter changes

(Before that commit, when type in 1 in the filter input box and click ok, then the filtered is not set. After that commit, the filter is set but NONE is shown which is wrong).

Adding Serge Krot to cc list - would you please take a look? thanks.
Comment 2 Xisco Faulí 2020-07-14 10:39:03 UTC
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: fa844c15233f108a0e9b0b2e8c9757c1aa088a4b
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

I also confirm the bisection in comment 1 is correct

Adding Cc: to Serge Krot
Comment 3 Julien Nabet 2020-09-19 09:26:48 UTC
I don't understand priority here.
I would rather put high priority since:
- it's a regression
- it's not a corner case
- it concerns all envs
Comment 4 Kevin Suo 2020-09-19 10:30:32 UTC
This is a minor issue as nobody would filter the result if there is only one record. But I agree to give it high priority to fix as it's a regression.
Comment 5 Xisco Faulí 2020-09-24 17:33:39 UTC
This happens when all the options are selected, not just when there's 1 entry.
For instance, A1-> a, A2-> 1, A3-> 2, A3->3. Autofilter, OK and all of them disappear. I think I know how to fix it
Comment 6 Commit Notification 2020-09-25 11:15:20 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fbcb6add21b889e20f67a7ef6e4e3c32ac1261d3

tdf#134351: do not apply autofilter if all entries are selected

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Kevin Suo 2020-09-25 14:05:42 UTC
I verify that the issue is fixed by this commit. Thank you!
Comment 8 Commit Notification 2020-10-04 09:44:59 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/40927b3792450142966cc7b5137ec6f084680d30

tdf#134351: do not apply autofilter if all entries are selected

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-10-04 09:46:18 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/0d7bba4df1ebd80fa033116d73cbe8c6d3807d15

tdf#134351: do not apply autofilter if all entries are selected

It will be available in 6.4.8.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-10-06 13:56:52 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-7":

https://git.libreoffice.org/core/commit/f68922349ee78a6a64c575e21fe323c442faa5da

tdf#134351: do not apply autofilter if all entries are selected

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.