Bug 134382 - Fontwork fill not properly rendered
Summary: Fontwork fill not properly rendered
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 134383 134384 (view as bug list)
Depends on:
Blocks: SoftEdgeFallout
  Show dependency treegraph
 
Reported: 2020-06-29 09:54 UTC by Telesto
Modified: 2020-09-08 12:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (19.15 KB, application/vnd.oasis.opendocument.presentation)
2020-06-29 09:54 UTC, Telesto
Details
Bibisect log (3.38 KB, text/plain)
2020-06-29 19:22 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-29 09:54:27 UTC
Description:
Fontwork fill not rendered in presentation mode

Steps to Reproduce:
1. Open the attached file
2. Press F5

Has something to do with the fill 45 degree blue (probably new since 7.0)

Actual Results:
No proper fill

Expected Results:
Same look as on file open


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 006c65bbd472cb1d7d44e095714e28190b76be0d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-06-29 09:54:39 UTC
Created attachment 162494 [details]
Example file
Comment 2 Telesto 2020-06-29 09:55:25 UTC
Adding bibisectrequest to find the person who implemented this. Looks like an implementation error
Comment 3 Telesto 2020-06-29 19:22:10 UTC
It should be blue lines.. fontwork is black (looks quite nice actually, but not the intended result)
Comment 4 Telesto 2020-06-29 19:22:46 UTC
Created attachment 162521 [details]
Bibisect log

Bisected to
author	Mike Kaganski <mike.kaganski@collabora.com>	2020-05-14 14:42:24 +0300
committer	Mike Kaganski <mike.kaganski@collabora.com>	2020-05-29 10:31:12 +0200
commit 82acd02f1395ea1a1b1e43c6b4beeec93ebf9428 (patch)
tree 017552883e8233fcf7d04d77c728c3bc82829bc4
parent a89d2a19930ba4f14bc498978664c45bfd3e8b58 (diff)
Use buffer with alpha in VclProcessor2D::RenderTransparencePrimitive2D
This allows TransparencePrimitive2D to produce truly transparent image,
usable later in the stack - specifically by soft edge effect.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=82acd02f1395ea1a1b1e43c6b4beeec93ebf9428
Comment 5 Telesto 2020-06-29 19:24:48 UTC
@Mike
It's still unconfirmed.. but properly one of your recent commits
Comment 6 Telesto 2020-06-29 19:25:23 UTC
*** Bug 134383 has been marked as a duplicate of this bug. ***
Comment 7 Telesto 2020-06-29 19:25:41 UTC
*** Bug 134384 has been marked as a duplicate of this bug. ***
Comment 8 Mike Kaganski 2020-06-29 21:30:37 UTC
It handles the hatch as non-transparent object, drawing solid shadow under the whole area instead of thin shadow lines under the hatch lines...
Comment 9 Mike Kaganski 2020-08-13 23:03:59 UTC
I believe it's fixed by https://git.libreoffice.org/core/commit/bf021c369f2306ee507da9bd3cc4cd10ac5d234c
Comment 10 Telesto 2020-08-27 19:26:00 UTC
Looks fine
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 6640d7f405d2970ba2825a9455926cc803284d01
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

@Mike -> I assume you want to take the credit.. so go ahead and set it to fixed
Comment 11 Xisco Faulí 2020-09-08 12:23:21 UTC
Closing as VERIFIED FIXED