Download it now!
Bug 134400 - FILEOPEN RTF (in Writer): Image missing/empty frame
Summary: FILEOPEN RTF (in Writer): Image missing/empty frame
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.1.0 target:7.0.1 target:6.4.7
Keywords: bibisected, bisected, regression
Depends on:
Blocks: RTF-Images
  Show dependency treegraph
 
Reported: 2020-06-29 18:22 UTC by Telesto
Modified: 2020-07-30 11:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (89.47 KB, application/vnd.oasis.opendocument.text)
2020-06-29 18:22 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-29 18:22:28 UTC
Description:
FILEOPEN RTF: Image missing/empty frame

Steps to Reproduce:
1. Open the attached file
2. Save as RTF
3. File Reload -> Empty frame in Writer; opens fine with Word

Actual Results:
Empty image frames

Expected Results:
Filled frame


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 006c65bbd472cb1d7d44e095714e28190b76be0d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

and in
6.0

and in
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL

but not when exported with
4.1 file opens on every version of LibO
Comment 1 Telesto 2020-06-29 18:22:44 UTC
Created attachment 162517 [details]
Example file
Comment 2 Xisco Faulí 2020-06-30 08:38:08 UTC
REproduced in

Version: 4.2.0.0.alpha1+
Build ID: fc8f44e82de4ebdd50ac5fbb9207cd1a59a927e3

but not in

Version: 4.1.0.0.alpha1+
Build ID: 863d38fbfa4fb4861e476828c46410602100919

it has to be bisected with 4.2 repo
Comment 3 Aron Budea 2020-07-04 14:30:08 UTC
Bibisected to the following commit using repo bibisect-42max. Note that I used an RTF saved in a current master build, and LO crashes right after opening the file in a range of commits around there, I could barely catch a glimpse of what the document looks like.
Adding CC: to Miklos Vajna.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=4ab658b56f5c6ff0082d38d8ace1924d11e30e96
author		Miklos Vajna <vmiklos@suse.cz>	2013-06-16 00:14:51 +0200
committer	Miklos Vajna <vmiklos@suse.cz>	2013-06-16 00:37:18 +0200

RTF import: implement support for tables inside text frames
Comment 4 Commit Notification 2020-07-21 06:53:25 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5a083be34456e91427d0f2e2fea172f49f4502db

tdf#134400 RTF import: fix unexpected inner properties for picture-in-textframe

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2020-07-21 15:19:46 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/ed714bd7ca70979340292b9d7a4b99b3a14db64c

tdf#134400 RTF import: fix unexpected inner properties for picture-in-textframe

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-07-22 09:20:17 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/5ccf0dac637345bab3d3a4e37ea6707c6d9bd0a6

tdf#134400 RTF import: fix unexpected inner properties for picture-in-textframe

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2020-07-30 11:57:52 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 231e1e416c039d1f9724962a89cf0573a3db48a2
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!