Bug 134420 - Select previous item after deleting an entry in the area fill tab list to avoid scrolling
Summary: Select previous item after deleting an entry in the area fill tab list to avo...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: low enhancement
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks: Area-Fill-Tab
  Show dependency treegraph
 
Reported: 2020-06-30 09:59 UTC by Telesto
Modified: 2020-08-04 15:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-30 09:59:16 UTC
Description:
UI: Dialog scrolls to top after deleting a background area bitmap

Steps to Reproduce:
1. Open Draw
2. Right Click on page -> Properties
3. Background -> Bitmap
4. Scroll down
5. Right click an item + delete

Actual Results:
Dialog scrolls to top

Expected Results:
Next in line gets selected.. 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 006c65bbd472cb1d7d44e095714e28190b76be0d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-06-30 10:00:15 UTC
Also in
Version: 6.0.5.0.0+
Build ID: 15ea1cda0b3c37ff944ad9a239b7ed453e8b0591
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 2 Thomas Lendo 2020-08-03 19:42:12 UTC
Confirmed with
Version: 7.1.0.0.alpha0+
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-07-30_20:15:28
Calc: threaded

This is the behavior in all Area fill tabs not only bitmaps.
Therefore changing summary from "UI: Dialog scrolls to top after deleting a background area bitmap" to "UI: Dialog scrolls to top after deleting an item in the area fill tab item list".

Heiko:
Is this something you would like to change?

From UX point of view I don't like any jump actions in the UI. So I support Telesto's request that the item before or after the deleted item should be selected; ideally the item after the deleted item which is replacing the deleted one and moving to the position of the deleted item.
Comment 3 Heiko Tietze 2020-08-04 08:17:52 UTC
(In reply to Thomas Lendo from comment #2)
> Heiko:
> Is this something you would like to change?
> 
> From UX point of view I don't like any jump actions in the UI. So I support
> Telesto's request that the item before or after the deleted item should be
> selected; ideally the item after the deleted item which is replacing the
> deleted one and moving to the position of the deleted item.

Rather before since it might be the last one.
Comment 4 Telesto 2020-08-04 09:27:32 UTC
@Caolan
You know they area pretty well, so might be interested in this one
Comment 5 Commit Notification 2020-08-04 14:59:46 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a1cb7ede7841de1cb38f260cecd5c067f0a8dac6

tdf#134420 select neighbour when deleted

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.