Download it now!
Bug 134582 - Edited forms created by older version of LO cannot be opened any more ( steps in comment 11)
Summary: Edited forms created by older version of LO cannot be opened any more ( steps...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.0.0.0.beta1+
Hardware: All All
: highest critical
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: odf target:7.1.0 target:7.0.0.2
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-07-06 19:37 UTC by jimishol
Modified: 2020-07-20 10:32 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (13.57 KB, application/vnd.oasis.opendocument.database)
2020-07-09 13:03 UTC, Xisco Faulí
Details
screencast (854.87 KB, video/x-matroska)
2020-07-09 18:53 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jimishol 2020-07-06 19:37:07 UTC
Description:
Database exist on postgresql server. Forms designed and used from a debian buster distribution. The odb file were copied to opensuse tumbleweed.
Works ok, if there is no editing of the form.
Even with minor editing, the saved form cannot be open and popups the message

The document 'bronze. connectons• could not be opened. 
SfxBaseModeHoadFrom Storage: Oxf26 'horn e/üNd/rmnt11Nd/BLJlLD/- 
libreoffice-7 _ O _ O _ O _ beta2/sfx2/source/doc/sfxbasernodel _ cxx8730

Steps to Reproduce:
1.Create a form in older version
2.open it with version 7 LO
3.Edit it and save
4. try to open it

Actual Results:
throws error

Expected Results:
should be opened for working on the database.
Should be opened as other new forms created by LO base version 7 do.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 7.0.0.0.beta2
Build ID: 00(Build:0)
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: el-GR (el_GR.utf8); UI: en-US
Calc: threaded
Comment 1 jimishol 2020-07-06 19:46:15 UTC
OCR didnt worked well. The correct message is

The document 'bronze.connections' could not be opened. 
SfxBaseModel::loadFrom Storage: Oxf26 home/abuild/rpmbuild/BUILD/- 
libreoffice-7.O.O.O.beta2/sfx2/source/doc/sfxbasemodel.cxx:3730
Comment 2 Robert Großkopf 2020-07-07 05:53:34 UTC
Could confirm the buggy behavior. 
I took a copy of a database, 
removed a field in the form,
saved the form and saved the database.
Then I tried to open the form and got:
Document ... could not be loaded
SfxBaseModel::loadFrom Storage: Oxf26 home/abuild/rpmbuild/BUILD/- 
libreoffice-7.O.O.O.beta2/sfx2/source/doc/sfxbasemodel.cxx:3730

Tested with OpenSUSE 15.1 64bit rpm Linux and a form, which has been created in the past with LO 5.* and last changed in LO 6.4.4.2.

Can't change the importance to high, but this is a stopper for Base.
Comment 3 Alex Thurgood 2020-07-07 15:37:39 UTC
Confirming with 
Version: 7.0.0.1
Build ID: 04ba7e3f1e51af6c5d653e543a620e36719083fd
CPU threads: 8; OS: Mac OS X 10.15.5; UI render: default; VCL: osx
Locale: fr-FR (fr_FR.UTF-8); UI: en-US
Calc: threaded
Comment 4 Alex Thurgood 2020-07-07 15:39:34 UTC
I tested this with an embedded hsqldb ODB file containing 1 form with multiple grid controls. Opened the form in form design mode, deleted a column from one of the grid controls, saved the form, then attempted to open the form normally for data entry.

Error message as indicated by the OP and Robert.
Comment 5 Dan Lewis 2020-07-07 15:50:11 UTC
 This also occurs LO 7.0.0.1 (RC1). This is on Ubuntu 18.04 (Debian) with an embedded database created by a version of the 2006-2007 period. I opened a form to edit. Then I deleted one of the controls. After saving the form and then the database, I attempted to open the form again for editing. The error message immediately appeared.
Comment 6 Rob Westein 2020-07-07 19:11:45 UTC
confirmed for LO 7.0.0.1 (RC1) Windows 10.
Comment 7 Xisco Faulí 2020-07-09 13:03:12 UTC
Created attachment 162846 [details]
sample file
Comment 8 Xisco Faulí 2020-07-09 13:04:11 UTC Comment hidden (obsolete)
Comment 9 Mike Kaganski 2020-07-09 15:50:18 UTC
It now correctly fails for the exception:

> Inconsistent ODF versions in content.xml and manifest.xml!

... so it seems we have a problem here that was discovered by the change. But in this case the form fails to open...
Comment 10 Mike Kaganski 2020-07-09 17:23:20 UTC
The problem is that for some reason, META-INF/manifest.xml contains manifest:version="1.2" for form object element (but "1.3" in all other cases).

But is there a sample file created in an older version, without the edits that create this problem?
Comment 11 Xisco Faulí 2020-07-09 18:51:38 UTC
ok, I've bisected it again and it seems to be an export issue, not an import issue.

Steps to reproduce it:
1. Open attachment 136485 [details] from bug 112590
2. Go to Forms - Right Click on Table1 - Edit
3. Change the position of any of the forms - Save - Close the document
4. Doubleclick on the form again.

-> The error is prompted

Regression introduced by:

author	Michael Stahl <Michael.Stahl@cib.de>	2020-04-28 18:04:14 +0200
committer	Michael Stahl <michael.stahl@cib.de>	2020-05-18 18:19:03 +0200
commit	a541cd91951eca15e40764244b34c72b347f9f26 (patch)
tree	4bc8d4dae54b42a65bd65239dc5283bcb667b23b
parent	101594c272a53727566b3533fd083178769a4b49 (diff)
officecfg,unotools,cui: add ODF 1.2 Extended / ODF 1.3 versions

Adding Cc: to Michael Stahl
Comment 12 Xisco Faulí 2020-07-09 18:53:29 UTC
Created attachment 162857 [details]
screencast
Comment 13 Michael Stahl (CIB) 2020-07-10 15:39:35 UTC
fixed on master
Comment 14 Commit Notification 2020-07-10 15:40:36 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/519d96fd8b83ef4c61576d87b58f97b7e6e6e3c6

tdf#134582 sfx2: when storing, set Version on embedded object storage

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-07-10 20:23:37 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/a24a4cc1838e3a2d55261a8edf6cb63186f4c38f

tdf#134582 sfx2: when storing, set Version on embedded object storage

It will be available in 7.0.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Xisco Faulí 2020-07-20 10:32:06 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: abea0d6647c7f1f7e76c73c26cb80e6a67dc5111
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this issue!!