Bug 134709 - FILEOPEN DOCX: left/right table borders missing in gridBefore and gridAfter situations
Summary: FILEOPEN DOCX: left/right table borders missing in gridBefore and gridAfter s...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2020-07-10 09:44 UTC by Justin L
Modified: 2020-07-21 10:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
gridBefore_gridAfter.docx: composed in MS Word 2003 (11.26 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-07-10 09:44 UTC, Justin L
Details
gridBefore_gridAfter_MSWord2003.pdf: printout of how it looks in Word 2003 (13.87 KB, application/pdf)
2020-07-10 09:46 UTC, Justin L
Details
Comparison MSO 2010 and LibreOffice 7.1 master (34.05 KB, image/png)
2020-07-10 16:42 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin L 2020-07-10 09:44:43 UTC
Created attachment 162872 [details]
gridBefore_gridAfter.docx: composed in MS Word 2003

In MS format's, tables are basically just rows connected together. A provision is made for "deleted" cells at the beginning and ending of every row. The outside table borders are supposed to apply to the first/last real cell in these cases, but LO doesn't apply the table border in these cases.

Steps to reproduce:
1.) open the attached docx.

EVERY row in the table should have a heavy border on the left and right side of the golden table cells, but in LO this is only happening on the outer cells without a gridBefore or gridAfter.

Note that the same is NOT true for top and bottom borders - which kindof makes sense since MS Format only knows about one row at a time.
Comment 1 Justin L 2020-07-10 09:46:57 UTC
Created attachment 162873 [details]
gridBefore_gridAfter_MSWord2003.pdf: printout of how it looks in Word 2003
Comment 2 Xisco Faulí 2020-07-10 16:42:26 UTC
Created attachment 162889 [details]
Comparison MSO 2010 and LibreOffice 7.1 master
Comment 3 Xisco Faulí 2020-07-10 16:42:51 UTC
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 12bfedfac3b141fe6c91b0e5ae5b3fb2ba817c48
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 4 Justin L 2020-07-11 06:56:51 UTC
partial fix proposed at gerrit.libreoffice.org/c/core/+/98534 tdf#134709 writerfilter: consider gridBefore for table borders

A followup commit can do the same thing for gridAfter, but currently gridAfter is not yet populated, so some foundational work needs to be done first.
Comment 5 Justin L 2020-07-13 19:19:59 UTC
proposed patch part2: http://gerrit.libreoffice.org/c/core/+/98692 tdf#134709 writerfilter: consider gridAfter for table borders
Comment 6 Commit Notification 2020-07-16 17:01:58 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fafc6c0fc3c6d62f982b0deb9bc1d874c51dd6fe

tdf#134709 writerfilter: consider gridBefore for table borders

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-07-21 07:17:44 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c3ca7e85ea27cb19475086e64b14e780c93910ca

tdf#134709 writerfilter: consider gridAfter for table borders

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.