Bug 134723 - extra pages printed with labels, mail merge
Summary: extra pages printed with labels, mail merge
Status: RESOLVED DUPLICATE of bug 48951
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Mail-Merge Additional-Blank-Pages
  Show dependency treegraph
 
Reported: 2020-07-10 21:27 UTC by bradhaack
Modified: 2021-04-12 13:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bradhaack 2020-07-10 21:27:33 UTC
Description:
When printing label pages using mail merge, an extra blank page is printed for each good page.   This can be avoided with File-'Printer Settings'-Options, but it looks like a bug to me since it isn't at all obvious that it is going to print blank pages and there doesn't seem to be a reason for it.

Steps to Reproduce:
1.File-new Labels
2.Print - print form letter
3.Print

Actual Results:
An extra blank page is printed for each good page

Expected Results:
Only the pages with addresses should be printed


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Timur 2020-07-12 15:22:00 UTC
This is a duplicate of bug https://bugs.documentfoundation.org/show_bug.cgi?id=48951. 
Option can be turned off in Options-Writer-Print.
It seems that default should be OFF and this could be an enhancement.
Comment 2 Timur 2020-10-16 08:41:23 UTC
I don't know why I wrote duplicate and didn't mark.

*** This bug has been marked as a duplicate of bug 48951 ***
Comment 3 Bill Sparrow 2021-04-12 13:09:49 UTC
Hi Timur

Thanks for looking at this, but in my opinion making the option "Print auto inserted blank pages" off by default is not a resolution to this issue.

When printing a book it is common practice to ensure that all chapters begin on a right hand page. The automatic way to achieve this, particularly when using duplex printing, is by making use of the predefined page styles called "Left Page" and "Right Page". Setting the page style of the first page of each chapter to "Right Page" ensures that, if the previous chapter ended on a right page, then LibreOffice will automatically insert a blank page. 

Contrast this with the issue that the system inserts blank pages for no obvious reason when using the mail-merge facility to print address labels.

So we have two cases - one is intentional and the other is an unwanted side effect of something I'm not sure I understand.

As I encounter both of these cases myself, I find I am in the position of having to remember to turn the option off when I want to print labels and on when I want to print a book.

Thanks for pointing out that "bug 134723" is similar to "bug 48951". I now see from reading all the comments in the earlier report that the issue there was probably caused by printing on the last available line on the page. This presumably triggered an ordinary page break before the mail-merge page break. In that report a resolution to the problem was to reduce the letter's length by one line so that there was no printing on the last available line of the page.

If I were to try to use that method to solve my label mail-merge problem would I have to reduce the number of merge fields so as to avoid printing on the last available line of each label? Or could I perhaps artificially decrease the bottom margin of the page to make room for an extra printable line which would remain unused?