Download it now!
Bug 134740 - Findind Text crashes calc
Summary: Findind Text crashes calc
Status: RESOLVED DUPLICATE of bug 132783
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-11 22:58 UTC by 3dcodewarrior
Modified: 2020-07-15 17:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
libreoffice --backtrace file (14.67 KB, text/plain)
2020-07-15 16:09 UTC, 3dcodewarrior
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 3dcodewarrior 2020-07-11 22:58:52 UTC
Hello,

Only crashes with on the sheets with a lot of data!

debug terminal message:  

/usr/include/c++/9/bits/stl_vector.h:1042: std::vector<_Tp, _Alloc>::reference std::vector<_Tp, _Alloc>::operator[](std::vector<_Tp, _Alloc>::size_type) [with _Tp = std::unique_ptr<ScColumn>; _Alloc = std::allocator<std::unique_ptr<ScColumn> >; std::vector<_Tp, _Alloc>::reference = std::unique_ptr<ScColumn>&; std::vector<_Tp, _Alloc>::size_type = long unsigned int]: Assertion '__builtin_expect(__n < this->size(), true)' failed.

Thank you
Regards
Comment 1 Xisco Faulí 2020-07-12 18:55:37 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 2 Xisco Faulí 2020-07-12 18:56:39 UTC
Could you please paste the info from Help - about LibreOffice ?
Comment 3 3dcodewarrior 2020-07-15 16:09:39 UTC
Created attachment 163068 [details]
libreoffice --backtrace file

Hello again,
  I'm sorry but I can't send you guys my Calc file, I attached the 'gdbtrace.log' (I think that the bug/error is described from line 50). If you guys need more info please detail what I have to do. Thanks!
Comment 4 3dcodewarrior 2020-07-15 16:49:10 UTC
help about libreoffice info:

Version: 6.3.6.2
Build ID: 6.3.6.2-4.fc31
CPU threads: 16; OS: Linux 5.7; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2020-07-15 17:27:01 UTC
It seems to be a duplicate of bug 132783.
Please, update to LibreOffice 6.4.5. The issue is fixed there

*** This bug has been marked as a duplicate of bug 132783 ***