Bug 134757 - Text formatting is removed on merge when content is not in first cell
Summary: Text formatting is removed on merge when content is not in first cell
Status: RESOLVED DUPLICATE of bug 89951
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.6.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Merge-Split
  Show dependency treegraph
 
Reported: 2020-07-12 18:53 UTC by BDF
Modified: 2020-09-16 13:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
image of bug (22.06 KB, image/png)
2020-07-12 18:53 UTC, BDF
Details
ods file for bug (13.60 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-07-12 18:59 UTC, BDF
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BDF 2020-07-12 18:53:02 UTC
Description:
When you enter data in a cell (eg A1), format it and then merge it (eg. with B1 and C1) the formating is kept.
When you enter data in a cell that is not the first cell of the combined ones (eg. data in B2 and merge is A2 to C2) the formatting is removed.

Steps to Reproduce:
1. enter data in a cell that is not the first one of the merged cells (eg. B1) and format it
2. select multiple cells (eg. A1 to C1) and merge them

Actual Results:
The formating (in the attached image it's font size 14 and bold font) is removed when the cell is merged

Expected Results:
The formating is kept when the cell is merged


Reproducible: Always


User Profile Reset: No



Additional Info:
For attached image:
1)
- Data is entered in line 1 AFTER merge in cell A1-C1
- Data is entered in line 3 BEFORE merge in cell A3
- Data is entered in line 5 BEFORE merge in cell B5

2)
- No format loss since the format is set after the merge
- No format loss on merge
- Format is LOST ON MERGE (since the format is kept when the data is entered in the first column, I would expect to see the same for data in the second column)

----

When you unmerge the cells (eg. A1 to C1, data in B1), the data is moved to the first cell (here A1), but the cell where the information was originally taken from (here B1) still has the original formation.

If you have multiple cells with data (eg. A1 with bold text, B1 with red text and C1 with yellow background) and merge them (mode to combine data in the first cell), the formating of the first cell is used. When the cell is unmerged, the content is moved to the first cell (here A1), but the other cells (here B1 and C1) keep their formating. This makes sense since you may would have to combine multiple values for the same setting (eg. font size 12 and font size 14)

If you use the option to delete the content of the hidden cells, the hidden cells (here B1 and C1) actually keep their formating even though their content is deleted.

If you combine one cell with data with multiple cells with no data and no format I would expect calc to copy the format.
If you combine one cell with data with multiple cells with no data but formating I have no idea what I would expect. Maybe calc asking me what I want to keep? But it would maybe faster to just set the formating like it was before.

----

Version: 6.4.4.2 (x64)
Build-ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU-Threads: 6; BS: Windows 6.1 Service Pack 1 Build 7601; UI-Render: Standard; VCL: win; 
Gebietsschema: de-AT (de_AT); UI-Sprache: de-DE
Calc: CL
Comment 1 BDF 2020-07-12 18:53:26 UTC
Created attachment 162932 [details]
image of bug
Comment 2 BDF 2020-07-12 18:59:57 UTC
Created attachment 162933 [details]
ods file for bug

First part above the line is the bug as you see it in the already attached image. 
Below the line (bold text, red text, yellow background) is the section described in the box for additional info.
Comment 3 Buovjaga 2020-07-22 15:36:44 UTC
Reproduced with master and 5.0.6 (did not try with older versions)

Version: 7.1.0.0.alpha0+
Build ID: 9006cbf6a13317a386194d6857f22391464c2aa0
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: kf5
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-07-16_00:51:18
Calc: threaded
Comment 4 NISZ LibreOffice Team 2020-09-16 13:10:09 UTC

*** This bug has been marked as a duplicate of bug 89951 ***