Bug 134818 - Copy/pasting bulleted list slowish (long post processing)
Summary: Copy/pasting bulleted list slowish (long post processing)
Status: CLOSED DUPLICATE of bug 113091
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-15 08:07 UTC by Telesto
Modified: 2020-08-07 05:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (16.08 KB, application/vnd.oasis.opendocument.text)
2020-07-15 08:07 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-15 08:07:09 UTC
Description:
Copy/pasting bulleted list slowish (long post processing)

Steps to Reproduce:
1. open the attached file
2. CTRL+A
3. CTRL+X
4. CTRL+V 8x

Actual Results:
20 seconds with 7.1
13 seconds with 4.4.7.2

Expected Results:
13 seconds but ideally even less


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: d851a02df57ab378ed0cc6d9362516de09c3279c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-07-15 08:07:24 UTC
Created attachment 163042 [details]
Example file
Comment 2 branding123 2020-07-25 08:12:37 UTC Comment hidden (spam)
Comment 3 branding123 2020-07-25 08:13:30 UTC Comment hidden (spam)
Comment 10 branding123 2020-07-25 08:31:23 UTC Comment hidden (spam)
Comment 17 branding123 2020-07-25 11:25:27 UTC Comment hidden (spam)
Comment 18 branding123 2020-07-25 11:29:32 UTC Comment hidden (spam)
Comment 20 branding123 2020-07-25 11:34:26 UTC Comment hidden (spam)
Comment 21 sora34ce 2020-08-06 20:05:36 UTC
I tried and this error does work with 20 seconds on 7.1.0.0. I thought it was because it was rapid, but I tried doing it slowly and it's still 20 seconds. A possibility is that it could require faster hardware, but this may be a hunch. Maybe you could give us some ideas on the format?
Comment 22 Telesto 2020-08-06 20:11:48 UTC
@Buovjaga,
Is there no way to remove the spam posts for the bugtracker? branding123 was quite active
Comment 23 Telesto 2020-08-06 20:13:48 UTC

*** This bug has been marked as a duplicate of bug 113091 ***
Comment 24 Buovjaga 2020-08-07 05:30:49 UTC
(In reply to Telesto from comment #22)
> @Buovjaga,
> Is there no way to remove the spam posts for the bugtracker? branding123 was
> quite active

Yes, changing status to closed will make a report a trap. If the posted comment or changed URL field contains a URL, the user will be automatically banned.