Bug 134870 - Fontwork can't be exported to SVG
Summary: Fontwork can't be exported to SVG
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: FontWork-WordArt SVG-Save
  Show dependency treegraph
 
Reported: 2020-07-16 15:15 UTC by Sven Strickroth
Modified: 2020-10-26 16:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A ODP file containing a FontWork object (13.91 KB, application/vnd.oasis.opendocument.presentation)
2020-07-16 15:15 UTC, Sven Strickroth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Strickroth 2020-07-16 15:15:19 UTC
Created attachment 163127 [details]
A ODP file containing a FontWork object

I have several presentations which cannot be displayed in full screen mode (Firefox 78 reports an XML error on the generated slideshow.svg which has 0 bytes size) in Nextcloud Collobora Online. I experimented a bit and it seems to boil down to Fotwork objects.

Steps to reproduce:
1. Upload an ODP presentation which contains a fontwork object (e.g., the attached presentation)
2. Open it with Collabora (the fontwork object is visible here)
3. Click on Menu Slide and select Full Screen Presentation
4. See an error in Firefox, Firefox complains that the file has not valid XML root element, indeed the slideshow.svg has a size of 0 bytes

I use Nextcloud 18.0.6 with the Collobora Online (richdocuments app) 3.7.3 and collaboraoffice6.2 (6.2.10.18-18) on the server side (Debian 9).

On the syslog I see the following error:
Jul 16 17:02:23 srv2 loolwsd[1250]: wsd-01250-02852 2020-07-16 15:02:23.198842 [ websrv_poll ] ERR  Download file [/opt/lool/child-roots/r1BRWJSB8svGjwMh/user/docs/EqkZpwJ75QfUO1of5dF5NaNfH1jWNl3ncZNXCbUX3Oy7IzJJ45YWSqPJkY9HgjRy/slideshow.svg] not found.| wsd/LOOLWSD.cpp:2934

Cross-ref: This issue was reported for the Nextcloud richdocuments app (<https://github.com/nextcloud/richdocuments/issues/1084>) before, but I was send here.
Comment 1 Aron Budea 2020-07-19 05:34:42 UTC
The problem is with LibreOffice's SVG export, when trying to do a File -> Export in Impress, and setting SVG output format, it gives "General input/ouput error," which explains the 0-byte result.

Checked with LO 7.1.0.0.alpha0+ (fa844c15233f108a0e9b0b2e8c9757c1aa088a4b) / Ubuntu.
Comment 2 Aron Budea 2020-10-17 07:18:22 UTC
This was actually a regression from the following commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=8fc1b60f62c213a0476f3acc9f89cd5eccbf335d
author		Miklos Vajna <vmiklos@collabora.com>	2020-02-27 09:34:30 +0100
committer	Miklos Vajna <vmiklos@collabora.com>	2020-02-27 10:33:24 +0100

"sw SVG export: try to reuse original bitmap data for JPG and PNG bitmaps"

And got fixed by:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=fbcdbfef8664430e15b9429187b58dede992accf
author		Miklos Vajna <vmiklos@collabora.com>	2020-09-07 17:00:44 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	2020-09-07 18:59:05 +0200

"SVG export: fix failure on trying to read graphic of a 3D shape"

It's also fixed in the current CODE/Collabora Online.
Comment 3 Xisco Faulí 2020-10-26 16:36:41 UTC
Setting to Verified based on comment 2