Bug 134884 - Impossible to filter a column by searching a letter/word and unchecking all checkboxes
Summary: Impossible to filter a column by searching a letter/word and unchecking all c...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2020-07-16 19:54 UTC by david.vantyghem
Modified: 2021-05-06 07:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
OK button is grey (9.25 KB, image/png)
2020-07-16 19:54 UTC, david.vantyghem
Details
Filtering a pivot table (19.11 KB, image/png)
2020-07-16 19:55 UTC, david.vantyghem
Details
File to test the filter (9.09 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-07-17 11:10 UTC, david.vantyghem
Details

Note You need to log in before you can comment on or make changes to this bug.
Description david.vantyghem 2020-07-16 19:54:26 UTC
Created attachment 163137 [details]
OK button is grey

In a column, I want to see only the cells that does not contains the letter "A".

1) I add autofilter at the top of the column.

2) In the autofilter, I type the letter A -> the autofilter shows me all the cells that contain this letter.

3) I uncheck all the boxes.

-> Impossible to click on the OK button because it becomes grey.


The button should stay normal and I should be able to click on it. All the cells that contains A should be hidden.

It's the same problem in a pivot table (see screenshot).
Comment 1 david.vantyghem 2020-07-16 19:55:21 UTC
Created attachment 163138 [details]
Filtering a pivot table
Comment 2 Xisco Faulí 2020-07-17 10:25:59 UTC
At least you need to have an item selected in order to apply the filter, otherwise there's nothing to filter. This is the expected behaviour.
If you don't want any option, use 'empty' option.
Closing as RESOLVED NOTABUG
Comment 3 david.vantyghem 2020-07-17 10:59:52 UTC
I disagree. If you want to filter to find all the cells that do not contain "A", the only way is to uncheck all cells containing "A". That how Excel and others software-like do. It's really a bug in Calc if the OK button is desactivated.
Comment 4 Xisco Faulí 2020-07-17 11:03:27 UTC
Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 5 david.vantyghem 2020-07-17 11:06:45 UTC
I already send 2 attachments, one showing that the OK button is grey.
Comment 6 david.vantyghem 2020-07-17 11:10:50 UTC
Created attachment 163171 [details]
File to test the filter

A join now another document to test with filtering with "A" letter in cells.
Comment 7 Xisco Faulí 2020-07-17 11:29:29 UTC
ok, I misunderstood your description. Thanks for providing all the required information.

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: d851a02df57ab378ed0cc6d9362516de09c3279c
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

and

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)


it seems like an enhancement to me
Comment 8 NISZ LibreOffice Team 2021-05-06 07:05:01 UTC
Excel has the "Add current selection to filter" metaitem for this purpose.

In Excel searching for "A" and unchecking it, then checking "Add current selection to filter" gives the expected result.

See: https://www.excelcampus.com/tips/filter-for-list/