Bug 134905 - Bad result after exporting to PNG file
Summary: Bad result after exporting to PNG file
Status: RESOLVED DUPLICATE of bug 134213
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
7.0.0.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: SoftEdgeFallout
  Show dependency treegraph
 
Reported: 2020-07-17 16:15 UTC by Petr Valach
Modified: 2020-07-18 08:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Source file (438.06 KB, application/vnd.oasis.opendocument.graphics)
2020-07-17 16:16 UTC, Petr Valach
Details
First page (172.37 KB, image/png)
2020-07-17 16:16 UTC, Petr Valach
Details
Second page (153.64 KB, image/png)
2020-07-17 16:17 UTC, Petr Valach
Details
Result from LO 6.4.5 (408.38 KB, image/png)
2020-07-17 16:19 UTC, Petr Valach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Valach 2020-07-17 16:15:40 UTC
Description:
After exportin to PNG file from Draw we get very bad results. Even text frames disappeare.

Steps to Reproduce:
1. Open file in attachment.
2. Go to menu File | Export.
3.Choose PNG type.

Actual Results:
First page - bad result, without correct transparency.
Second page - all text frames disappeared, bad transparency result.

Expected Results:
Result matches source file, as we get from LibreOffice 6.4.5.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.0.0.1
Build ID: 04ba7e3f1e51af6c5d653e543a620e36719083fd
CPU threads: 2; OS: Linux 5.3; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
Comment 1 Petr Valach 2020-07-17 16:16:19 UTC
Created attachment 163192 [details]
Source file
Comment 2 Petr Valach 2020-07-17 16:16:39 UTC
Created attachment 163193 [details]
First page
Comment 3 Petr Valach 2020-07-17 16:17:06 UTC
Created attachment 163194 [details]
Second page
Comment 4 Petr Valach 2020-07-17 16:19:08 UTC
Created attachment 163195 [details]
Result from LO 6.4.5
Comment 5 Petr Valach 2020-07-17 16:22:58 UTC
One important moment - you should check field Save transparency. But you will get really different results.
Comment 6 raal 2020-07-17 16:43:20 UTC
Confirm with Version: 7.1.0.0.alpha0+
Build ID: fa844c15233f108a0e9b0b2e8c9757c1aa088a4b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
Comment 7 raal 2020-07-17 17:03:19 UTC
This seems to have begun at the below commit.
Adding Cc: to Mike Kaganski ; Could you possibly take a look at this one?
Thanks
 1346a232e449ab004077d170510ae00e5409680f is the first bad commit
commit 1346a232e449ab004077d170510ae00e5409680f
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Jun 2 01:48:09 2020 +0200

    source sha:8c84448febf817875ad0d377de0f0b34987992cb

https://gerrit.libreoffice.org/c/core/+/94969
Use buffer with alpha in VclProcessor2D::RenderUnifiedTransparencePrimitive2D
Comment 8 Robert Großkopf 2020-07-18 07:49:22 UTC
Isn't this a duplicate of https://bugs.documentfoundation.org/show_bug.cgi?id=134213 ?
Comment 9 Petr Valach 2020-07-18 08:27:37 UTC

*** This bug has been marked as a duplicate of bug 134213 ***