Bug 134958 - Persona/Theme cannot be imported or customised on a per-application basis
Summary: Persona/Theme cannot be imported or customised on a per-application basis
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: LibreOffice-Themes
  Show dependency treegraph
 
Reported: 2020-07-19 14:27 UTC by Darren John de Lima
Modified: 2021-01-20 16:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Darren John de Lima 2020-07-19 14:27:19 UTC
Description:
LibreOffice >> Tools >> Options >> Personalization does not allow the user to import their own Personas; the only way to do so is to hack around with LibreOffice program files. 

It would also be desirable to customise the persona on a per-application basis, allowing different colours to be used for Writer, Calc, Impress, etc. in line with the identifiable branding now used in the help documentation: https://wiki.documentfoundation.org/File:Colorhelp.png

Would it be possible to fix these issues?

Steps to Reproduce:
1. Goto LibreOffice >> Tools >> Options >> Personalization


Actual Results:
1. The user can only choose "No theme" or "preinstalled theme"
2. The user cannot import their own correctly formatted images as themes, but must hack around with and replace the preinstalled themes.
3. Themes apply across all LibreOffice programs

Expected Results:
1. The user should be able to import their own correctly formatted images as a persona.

2. Individual themes should apply to individual programs, e.g. as is being done with the help documentation in v7: https://wiki.documentfoundation.org/File:Colorhelp.png


Reproducible: Always


User Profile Reset: No



Additional Info:
I put the "earliest affected version" as my current version, v6.4.3.2, but I believe this problem with theming affects all versions of LibreOffice.
Comment 1 Darren John de Lima 2020-08-03 16:18:33 UTC
Just commenting here, as I received an email saying the "bug" needs "comment".

It's still present. The user cannot customise the persona/theme on a per-application basis within LibreOffice, nor can they import custom themes of their own making (without hacking around with LibreOffice program files).
Comment 2 Heiko Tietze 2021-01-20 16:08:24 UTC
Mozilla has changed the format repeatedly making it hard to keep track. So bug 125217 recommends to introduce an own theming engine/method.

WF, since we do not plan to fix issues on the Mozilla type of personalization.