Download it now!
Bug 134979 - Relative is lost if relative is checked on table tab & go the column tab & press OK
Summary: Relative is lost if relative is checked on table tab & go the column tab & pr...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2020-07-20 11:54 UTC by Telesto
Modified: 2020-12-25 16:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (8.41 KB, application/vnd.oasis.opendocument.text)
2020-07-20 11:54 UTC, Telesto
Details
bibisect-linux-64-6.3, tail of terminal output (2.95 KB, text/plain)
2020-07-27 20:16 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-20 11:54:01 UTC
Description:
Relative is lost if relative is checked on table tab & go the column tab & press OK

Steps to Reproduce:
1. Open the attached file
2. Table -> Properties -> Table tab
3. Check relative
4. Click the Column tab
5. Press OK
6. Table -> Properties -> Notice that column width being absolute

Actual Results:
Absolute

Expected Results:
Relative


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
7.1

and in
Version: 6.2.4.0.0+
Build ID: 915ec0b5f5ce9a2da6a51f5278ea4faaffa19839
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

but not in
6.0
Comment 1 Telesto 2020-07-20 11:54:21 UTC
Created attachment 163313 [details]
Example file
Comment 2 melda researchers 2020-07-21 06:15:59 UTC Comment hidden (spam)
Comment 3 BogdanB 2020-07-22 18:35:55 UTC
It's relative in

Version: 6.4.5.2
Build ID: a726b36747cf2001e06b58ad5db1aa3a9a1872d6
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 BogdanB 2020-07-22 18:36:58 UTC
It's relative in
Version: 7.1.0.0.alpha0+
Build ID: abea0d6647c7f1f7e76c73c26cb80e6a67dc5111
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 5 Telesto 2020-07-22 19:00:37 UTC
(In reply to BogdanB from comment #4)
> It's relative in
> Version: 7.1.0.0.alpha0+
> Build ID: abea0d6647c7f1f7e76c73c26cb80e6a67dc5111
> CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
> Locale: ro-RO (ro_RO.UTF-8); UI: en-US
> Calc: threaded

True, with GTK3 not with GEN
Comment 6 BogdanB 2020-07-22 19:28:49 UTC
Confirm in
Version: 7.1.0.0.alpha0+
Build ID: abea0d6647c7f1f7e76c73c26cb80e6a67dc5111
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: x11
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 7 Terrence Enger 2020-07-27 20:16:59 UTC
Created attachment 163657 [details]
bibisect-linux-64-6.3, tail of terminal output

Working on debian-buster in bibisect-linux-64-6.3 repository I have localized the introduction of the bug to:

          commit    s-h       date
    good  c654e995  e00d5f21  2019-01-10 07:27:27
    bad   48fd367d  cf6df180  2019-01-10 07:28:19

The message on that commit is:

    Author:     Noel Grandin <noel.grandin@collabora.co.uk>
    AuthorDate: Wed Jan 9 15:14:46 2019 +0200
    Commit:     Noel Grandin <noel.grandin@collabora.co.uk>
    CommitDate: Thu Jan 10 08:28:19 2019 +0100

        fix leak in SwDrawFrameFormat::GetDescription
    
        and simplify.
    
        ever since original code was committed in
            commit da12dc5adf9086d418ff0d09abee23fdd8f68cda
            Date:   Wed Sep 8 14:20:23 2004 +0000
            INTEGRATION: CWS swundo03 (1.48.34); FILE MERGED
    
        Change-Id: I9aae40eade34051219f1fe838b373e0f3317d2c6
        Reviewed-on: https://gerrit.libreoffice.org/66026
        Tested-by: Jenkins
        Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>


I am removing keyword bibisectRequest and adding bibisected, bisected.
Comment 8 Telesto 2020-07-27 22:12:23 UTC
Adding CC: to Noel Grandin
Comment 9 Telesto 2020-08-05 14:56:41 UTC
@Caolan
As I'm already 'spamming' you with lovely table dialog bugs, another one. Only if you're interested of course.
Comment 10 Caolán McNamara 2020-08-05 15:28:41 UTC
I see it in 7-0, reverting the bisected commit doesn't make any difference so I don't think that's right. It seems to be a duplicate of tdf#134913 to me
Comment 11 Terrence Enger 2020-08-05 18:34:19 UTC
(In reply to Caolán McNamara from comment #10)
> I see it in 7-0, reverting the bisected commit doesn't make any difference
> so I don't think that's right. It seems to be a duplicate of tdf#134913 to me

Sigh!  Going back to the version I reported "bad", I see a mixture of
bad and good results.  Using a fresh user profile each time, I have 5
successive good results from each of the versions I reported "good"
and "bad".  Now, I cannot ever reproduce the problem in my local build
of master (which is older than the patch pushed for bug 134913).

I am putting keywords back like I found them.  I apologize for the
noise.
Comment 12 Telesto 2020-08-05 19:01:36 UTC
(In reply to Caolán McNamara from comment #10)
> I see it in 7-0, reverting the bisected commit doesn't make any difference
> so I don't think that's right. It seems to be a duplicate of tdf#134913 to me

Lets hope it's fixed.. will check tomorrow
Comment 13 raal 2020-12-25 16:57:26 UTC
Works for me in Version: 7.2.0.0.alpha0+
Build ID: 2577d9ecea199ca2c10d852cf279053a1b22faf7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
and Version: 7.2.0.0.alpha0+
Build ID: 2577d9ecea199ca2c10d852cf279053a1b22faf7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded