Bug 134999 - Failure in allowing to choose what section to link from another file
Summary: Failure in allowing to choose what section to link from another file
Status: RESOLVED DUPLICATE of bug 129881
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Section
  Show dependency treegraph
 
Reported: 2020-07-21 01:35 UTC by Felipe Viggiano
Modified: 2020-08-08 20:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felipe Viggiano 2020-07-21 01:35:47 UTC
Description:
While trying to link sections between .odt files, LibreOffice failed to allow me to choose wic section from the file I want to link.

Steps to Reproduce:
1.Create a .odt file with 2 different sections in it (put some different text in each section to make it easier to visualize).
2. Save and close the file.
3. Create a new .odt file and insert one section.
4. Go to EDIT SECTION in the context menu, and link it with the previous file.

Actual Results:
All sections are inserted in the new document.

Expected Results:
The LO Writer should allow you to choose wich section to link.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.4.2
Build ID: 1:6.4.4-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: pt-BR (pt_BR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Dieter 2020-08-04 12:50:40 UTC
I can't confirm it with

Version: 7.0.0.0.beta2 (x64)
Build ID: 1c213561a365b5666167321de68c9977500c9612
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Not clear from your steps, if you selected one section. Might be related to bug 129881. So could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/current.html ? You can install it alongside the standard version. I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build.
Comment 2 Felipe Viggiano 2020-08-08 20:57:19 UTC
Yeah, this was exactly like the 129881 bug.

I can confirm that in the latest release of LibreOffice 7.0 this bug was fixed.

Confirm bug fixed in: 

Version: 7.0.0.3
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: threaded

*** This bug has been marked as a duplicate of bug 129881 ***