Bug 135364 - Pen color and width not stored under Gtk (see comment 9)
Summary: Pen color and width not stored under Gtk (see comment 9)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0 target:7.0.6 target:7.1.3
Keywords: accessibility
: 141139 (view as bug list)
Depends on:
Blocks: a11y GTK3
  Show dependency treegraph
 
Reported: 2020-08-01 13:58 UTC by bchemnet
Modified: 2021-03-30 09:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bchemnet 2020-08-01 13:58:41 UTC
Description:
I have recently been making extensive use of the "pen" feature of drawing on slides during presentations.  However, I prefer a different color and pen width than the default.  I have been unable to find any setting, even in the expert mode, that allows me to change these from "red" & "normal" to my preferred settings.  Therefore I have to change these every time I start a presentation.

Would it be possible to add a setting somewhere, even if hidden, that allows these to be user-configurable?  Even simply saving these settings as part of the presentation, as is done with the drawings on the slides themselves, would be a major improvement because at least I could set the values in advance of starting a live presentation.

I apologize if there is such a setting now, but I certainly could not discover it if so.

Steps to Reproduce:
1.Load a presentation.
2.Start slideshow.
3.Change settings.

Actual Results:
Must manually select pen width and color every time load a presentation.

Expected Results:
Save or change defaults for these settings.


Reproducible: Always


User Profile Reset: No



Additional Info:
N/A
Comment 1 Heiko Tietze 2021-03-18 11:25:42 UTC
We reviewed the default in the design meeting and think red/normal are sane values. Whatever you define is stored and used in the next session, so you can easily change the default. => WF/NAB
Comment 2 bchemnet 2021-03-18 11:43:26 UTC
(In reply to Heiko Tietze from comment #1)
> Whatever you define is stored and used in the next session, so you
> can easily change the default. => WF/NAB

This is not the case for me.  No matter what I change or save, the pen reverts to the defaults as soon as I end a presentation.  Even resuming the presentation in the same session, the pen reverts.  If the setting was saved,then I would be fine with leaving the default as is.  But it is neither saved nor can the default be changed.
Comment 3 Heiko Tietze 2021-03-18 12:02:44 UTC
WFM in "still"

Version: 7.0.5.2
Build ID: 00(Build:2)
CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: kf5
Locale: de-DE (en_US.UTF-8); UI: en-US
7.0.5-1
Calc: threaded

(except mouse pointer as pen on/off, which makes sense)
Comment 4 bchemnet 2021-03-18 12:18:18 UTC
(In reply to Heiko Tietze from comment #3)
> WFM in "still"

Can I ask what you are doing that makes it work for you?  I just started a brand new presentation (in case it is a problem with my existing files), changed default to show pen (this does save), started presentation, changed pen, used it, end presentation.  Restart presentation, and I am back to medium/red.  Same behavior if I save and reload - pen reverts.

I am currently on 7.0.3 and in the middle of many things so can not immediately update, but I am not aware of any recent changes that would impact this behavior.
Comment 5 Regina Henschel 2021-03-18 13:36:01 UTC
I have tested it with Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 076da4cd9d61adf15942a7bfc350bd0d268f64f1
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL

I have set "Mouse pointer as pen" in the slide show settings, run the presentation and change pen width/color and draw something, leave presentation, save it, close it. When I reopen the presentation and go into show mode, the pen has the color and width, which I have last used.

Please try a daily build (which will become version 7.2). It can be installed parallel to your regularly version. https://dev-builds.libreoffice.org/daily/master/
Comment 6 Heiko Tietze 2021-03-19 09:10:28 UTC
(In reply to bchemnet from comment #4)
> Can I ask what you are doing that makes it work for you?

Works out of the box. My "still" version is what the Linux distribution installs, and I'm running in parallel self-compiled main version.
Comment 7 bchemnet 2021-03-20 01:56:28 UTC
Thank you for the responses.  Upon testing further, I apologize for the unnecessary noise here - the feature does work precisely as I would like, when it works.

It appears that this a problem with the gnome-integration package.  As soon as I disable the gnome/gtk3 interface, the feature works perfectly.  Turn that interface back on, and suddenly libreoffice no longer remembers any changes to those settings - but now it will revert to whatever the last settings I used prior to reactivating.

So this actually a bug that the GTK overlays are somehow blocking the recording of the changes to the pen settings, and not an issue with the basic Impress behavior.  I will open a new bug that focuses on that aspect.
Comment 8 Heiko Tietze 2021-03-22 11:57:36 UTC
Caolan, what do you think?
Comment 9 Caolán McNamara 2021-03-22 16:02:12 UTC
(In reply to Heiko Tietze from comment #8)
> Caolan, what do you think?

the dtor of ShowWindow isn't getting called, so the pen color preference isn't saved. The dtor isn't getting called due to some complicated a11y ownership problem so its apparently an a11y related issue seen under gtk cause a11y is always-on there
Comment 10 Caolán McNamara 2021-03-23 12:48:22 UTC
accessibility is keeping the impress/draw windows alive beyond what it should
Comment 11 Commit Notification 2021-03-24 15:17:35 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/493393d651ec32fd9cfbeb05f51253f70f4c0a87

Resolves: tdf#135364 ensure the window is released by a11y dispose

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Caolán McNamara 2021-03-24 15:30:36 UTC
fixed in main, backports to 7-1 and 7-0 in gerrit
Comment 13 bchemnet 2021-03-25 02:29:40 UTC
*** Bug 141139 has been marked as a duplicate of this bug. ***
Comment 14 bchemnet 2021-03-25 02:31:58 UTC
Thank you.
Comment 15 Commit Notification 2021-03-30 09:40:08 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/c9f08c3008984039f18c23aab3f6690e3ae27649

Resolves: tdf#135364 ensure the window is released by a11y dispose

It will be available in 7.0.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2021-03-30 09:41:22 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/38f678a357b3f8c179a91da013593156b7f95ab4

Resolves: tdf#135364 ensure the window is released by a11y dispose

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.