Bug 135403 - i18n: add Ido language
Summary: i18n: add Ido language
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Languages
  Show dependency treegraph
 
Reported: 2020-08-03 08:50 UTC by José Miguel
Modified: 2021-11-25 01:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description José Miguel 2020-08-03 08:50:55 UTC
We have created a new spelling dictionary for the Ido language. It is an international auxiliary language (https://io.wikipedia.org/wiki/Ido).

However, we cannot add the dictionary because the name of the language does not appear in the list of possible languages in the Options menu of LibreOffice.

The ISO 639-1 code es [io]. The ISO 639-2 code is [ido]. I suppose it should be written as io-IO, because there are no differences between countries.

Thank you,

José Miguel.
Comment 1 Xisco Faulí 2020-08-04 11:40:12 UTC
@Eike, I thought you might be interested in this issue
Comment 2 Eike Rathke 2020-08-05 09:12:09 UTC
Fwiw, if a dictionary is defined (e.g. in the dictionaries.xcu file's Locales property) for languages/locales that are not present as builtin then those are listed on top of the languages list surrounded by {} braces, for example {io}. This only in the text / font / character attribution, the default document language under Tools->Options lists only languages/locales with locale data.

However, the locale 'io-IO' would be wrong as the ISO 3166 country code 'IO' designates the British Indian Ocean Territory, see https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2#IO

Just use the plain language code 'io' instead.

I don't think we need yet another predefined entry in the language list for this.
Comment 3 Xisco Faulí 2021-11-23 11:07:36 UTC
Closing as RESOLVED WONTFIX based on comment 2
Comment 4 Eike Rathke 2021-11-25 01:09:00 UTC
Additionally, in 7.3 a language tag from a dictionary will have a more verbose Language list entry generated, in this case "Ido {io}".

If you plan to also submit locale data to have the locale available including number formats and calendar data, and having it selectable as default document language, then please feel free to reopen this issue.

For how to contribute locale data please see
https://wiki.documentfoundation.org/LibreOffice_Localization_Guide/How_To_Submit_New_Locale_Data