Bug 135445 - Character spacing inconsistent (depending on zoom level). Sometimes melted to each other
Summary: Character spacing inconsistent (depending on zoom level). Sometimes melted to...
Status: RESOLVED DUPLICATE of bug 103322
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-04 17:49 UTC by Telesto
Modified: 2020-08-04 18:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (41.44 KB, image/png)
2020-08-04 17:51 UTC, Telesto
Details
Screenshot at 120 (even more obvious) with magnifier 200 (45.84 KB, image/png)
2020-08-04 18:00 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-04 17:49:10 UTC
Description:
Character spacing inconsistent (depending on zoom level). Sometimes melted to each other

-> I probably end up at floating point calculations etc, but only to be certain

Steps to Reproduce:
1. Open Writer
2. Type or copy/paste oeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoeoe
3. Take certain zoom level (for me it's working at 130%)
4. If needed the MS magnifier tool and look at the line.. There are cases where stuff blends into each other

Actual Results:
Spacing between characters inconsistent

Expected Results:
Ideally stable


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: ru-RU (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-08-04 17:51:57 UTC
Created attachment 163944 [details]
Screenshot
Comment 2 Telesto 2020-08-04 18:00:12 UTC
@V Stuart
I'm probably repeating the same thing here (so bug 103322). But is the calculation really that erratic; so producing such a pattern. Or is there also something else influencing the outcome
Comment 3 Telesto 2020-08-04 18:00:44 UTC
Created attachment 163945 [details]
Screenshot at 120 (even more obvious) with magnifier 200
Comment 4 Telesto 2020-08-04 18:11:40 UTC
I do notice the 'grouping' also in Impress, but not they blending
Comment 5 V Stuart Foote 2020-08-04 18:28:41 UTC
@Telesto, IIUC those varying VCL canvas spacings on a line of text at differing zoom level is exactly the requirement Khaled laid out for improving the Harfbuzz based layout. The FP (or alternative integer scaling) is also needed for correctness in sub-pixel rendering, a.k.a ClearType rendering support.

*** This bug has been marked as a duplicate of bug 103322 ***