Bug 135467 - EDITTING FUNCTIONS RANDBETWEEN.NV
Summary: EDITTING FUNCTIONS RANDBETWEEN.NV
Status: CLOSED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: implementationError
Depends on:
Blocks: Calc-Function
  Show dependency treegraph
 
Reported: 2020-08-05 16:05 UTC by Luuk
Modified: 2020-08-17 10:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
RANDBETWEEN.NV.ods (14.05 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-08-05 16:05 UTC, Luuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luuk 2020-08-05 16:05:20 UTC
Created attachment 163979 [details]
RANDBETWEEN.NV.ods

When positioned at cell A5, and pressing the 'F9' button

- The fields in column C do get recalculated => OK
- The fields in column E do get recalculated => OK
- The fields in column F are recalculated from row 5 and higher => NOT OK

(see attached file "RANDBETWEEN.NV.ods")
Comment 1 Luuk 2020-08-05 16:06:55 UTC
When position at cell A6 and pressing 'F9', the values from row 6, and higher, are recalclutaed.....
Comment 2 Luuk 2020-08-05 16:19:35 UTC
This bug was checked on the following installations:

Version: 7.0.0.3
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 3 m.a.riosv 2020-08-08 01:16:10 UTC
Reproducible.
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 10.0 Build 20180; UI render: Skia/Raster; VCL: win
Locale: es-ES (es_ES); UI: en-US, Calc: threaded
Comment 4 Eike Rathke 2020-08-17 10:54:59 UTC
Hitting F9 on a cell sets that cell dirty and broadcasts it (and thus all dependants) and recalculates them. So A6:A11 are also affected. Not a bug.