Bug 135594 - Unable to access a file in server using convertToUrl in a macro
Summary: Unable to access a file in server using convertToUrl in a macro
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Macro
  Show dependency treegraph
 
Reported: 2020-08-10 09:23 UTC by karadaidis
Modified: 2020-10-19 11:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
error message (14.71 KB, image/jpeg)
2020-08-10 09:23 UTC, karadaidis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description karadaidis 2020-08-10 09:23:33 UTC
Created attachment 164090 [details]
error message

I used   the following   macro in BASE to open a file stored in  the server until version 6.4.5.2 (64)of LO. (win 10 pro /2004.

sub open_file
'-----------------
    oform = thisComponent.drawpage.forms.MainForm
    surl = convertToUrl(oform.getstring(oform.findcolumn("URL")))
    if surl = "" then
        msgbox ("No Url found",16,"Error")
        exit sub
    endif
    oShell = createUnoService("com.sun.star.system.SystemShellExecute")
    oShell.execute(surl,,0)
end sub

After updating to LO 7.0.03 I get an error message (attached) saying that " Windows can not find the file:///Z:/%CE.......". Be sure that you typed the correct name and try again.
Comment 1 karadaidis 2020-08-12 05:39:07 UTC
After I reinstalled 6.4.5 everything was OK
Comment 2 karadaidis 2020-08-12 05:39:57 UTC Comment hidden (obsolete)
Comment 3 Robert Großkopf 2020-08-12 19:53:52 UTC
Hi karadaidis,

you can't confirm you own bugs. There must be somebody, who could reproduce the buggy behavior. You could add a little example here so somebody could reproduce ist.
Comment 4 karadaidis 2020-08-19 05:15:02 UTC
i found the cause of the problem.
Until LO 6.4.5 you have to use convertToUrl( ), but in LO 7.0 need not to use this, just the string.See the sub open_file.
Comment 5 Alex Thurgood 2020-09-14 09:06:32 UTC
This is an API change, so not a bug.
Comment 6 Robert Großkopf 2020-10-19 09:43:25 UTC
(In reply to karadaidis from comment #4)
> i found the cause of the problem.
> Until LO 6.4.5 you have to use convertToUrl( ), but in LO 7.0 need not to
> use this, just the string.See the sub open_file.

So should this bug be closed as Worksforme?