Bug 135629 - Character can be deleted without image deletion if a second paragraph if present, else image deleted with character
Summary: Character can be deleted without image deletion if a second paragraph if pres...
Status: RESOLVED DUPLICATE of bug 134007
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Anchor-and-Text-Wrap
  Show dependency treegraph
 
Reported: 2020-08-11 09:15 UTC by Telesto
Modified: 2021-08-05 16:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (671.70 KB, application/vnd.oasis.opendocument.text)
2020-08-11 09:16 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-11 09:15:49 UTC
Description:
Character can be deleted without image deletion if a second paragraph if present, else image deleted with character

Steps to Reproduce:
1. open the attached file
2. Place the cursor after the X & press backspace -> Image still present
3. CTRL+Z
4. Go to the second line, press backspace -> Cursor goes up to first
5. Now press backspace again X + image deleted

Actual Results:
Anchor deleted together with character. Should be split. Deleting a anchor is separate action (not related to the character). As there are enough cases where this is possible.

the current behaviour is certainly inconsistent/ circumstantial which makes it unexpected

Expected Results:
As said, deleting an anchor is separate action


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.2
Build ID: c01aa64b6c3d89ebe5fe69c28c7adb24eb85249c
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; VCL: osx
Locale: nl-NL (nl_NL.UTF-8); UI: en-US
Calc: threaded
Comment 1 Telesto 2020-08-11 09:16:14 UTC
Created attachment 164145 [details]
Example file
Comment 2 Dieter 2021-03-05 17:36:47 UTC
Telesto, unfortunately nothing has happened with this bug report for more than half year. So I'd like to ask, if it is still valid. Could you please try to reproduce it with the latest version of LibreOffice?
=> NEEDINFO
Comment 3 Telesto 2021-03-05 18:32:53 UTC
Still around
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 722ec600e85cca2e94e82e69f8d13773061172b9
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: nl-NL
Calc: CL
Comment 4 Telesto 2021-03-05 18:34:31 UTC
Still OK in
Version: 6.2.9.0.0+ (x86)
Build ID: 5f01fe15eb2661f1f9ce12d1d99dc2a705b462ee
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 5 Dieter 2021-03-06 06:02:57 UTC
I confirm this with

Version: 7.1.1.2 (x64) / LibreOffice Community
Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL
Comment 6 psidiumcode 2021-08-02 18:19:38 UTC
I could reproduce it in versions:

Version: 7.1.0.0.alpha0+
Build ID: 3870dd43e94c440a5094a57c47d3b7565658d73c
CPU threads: 12; OS: Mac OS X 10.15.7; UI render: default; VCL: osx
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

Version: 7.1.0.0.beta1+
Build ID: d5e786d78d2f72a39f02746d6e0faa04da72c60a
CPU threads: 12; OS: Mac OS X 10.15.7; UI render: default; VCL: osx
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

Version: 7.0.6.2
Build ID: 144abb84a525d8e30c9dbbefa69cbbf2d8d4ae3b
CPU threads: 12; OS: Mac OS X 10.15.7; UI render: default; VCL: osx
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 7c38362dbe1922c9825dffb463072030948d406b
CPU threads: 12; OS: Mac OS X 10.15.7; UI render: default; VCL: osx
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

But I could not reproduce it in version:

Version: 6.4.0.0.beta1+
Build ID: d54bae3471e9b9529f1ac03c811c3370d9f5ed89
CPU threads: 12; OS: Mac OS X 10.15.7; UI render: default; VCL: osx; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Buovjaga 2021-08-05 16:24:25 UTC
Bibisected to
https://git.libreoffice.org/core/commit/91b2325808a75174f284c48c8b8afc118fad74e4

But another report exists, so duping to it

*** This bug has been marked as a duplicate of bug 134007 ***