Bug 135644 - LO & identifies Java 14.x as defective on MacOS Catalina
Summary: LO & identifies Java 14.x as defective on MacOS Catalina
Status: RESOLVED DUPLICATE of bug 135479
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-11 19:11 UTC by Marc Grober
Modified: 2020-08-26 16:08 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Grober 2020-08-11 19:11:48 UTC
Description:
Have had a working and regularly upgraded LO6.x for quite a while now
using Oracle Java JDKs 12, 14, and now 14.0.1 (MacOS Catalina)

Today I tried to move to LO7.0.0 and  BOINNNGGGGGG....   I have received
the dreaded message that says that my installed java is DEFECTIVE and I should install a working version. Tis happened with Oracle  java 14 and 14.0.1

Of course, my java installation is working JUST FINE in 6.x (still) and has been
functional with LibreOffice and Zotero.

So, it appears something was tweaked in LO7 that does not
like Oracle java 14.0.1.



Steps to Reproduce:
1. Install LO7
2. Run LO7

Actual Results:
all one has to do is run LO7 with Oracle java installed nd LO7 throws an error message hat java is defective. I have reinstalled LO7 and reinstalled java. Even updated to Oracle java 14.0.2-- no change

Expected Results:
simple open and allow selection of java. the app does finally open, but nothing employing java works (Zotero) no matter the version selected.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version 6 is still working.
Comment 1 Marc Grober 2020-08-14 20:09:49 UTC
I have added current notes about how LO7 will work with oracle java 12 and discussion on Zotero forum into the related bug
Comment 2 Alex Thurgood 2020-08-26 07:31:38 UTC
@Marc, is this not a DUP of bug 135479 ?
Comment 3 Marc Grober 2020-08-26 16:08:33 UTC
@Alex
I I did not find the other two bugs when I posted. Add as related. Now it is clear that both later bugs are dups.

*** This bug has been marked as a duplicate of bug 135479 ***