Bug 135756 - CSV file opening error of version 7
Summary: CSV file opening error of version 7
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CSV-Import
  Show dependency treegraph
 
Reported: 2020-08-14 11:34 UTC by Kouichi Nakamura
Modified: 2020-08-15 07:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A CSV file for testing. (1.30 KB, text/csv)
2020-08-14 11:34 UTC, Kouichi Nakamura
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kouichi Nakamura 2020-08-14 11:34:17 UTC
Created attachment 164309 [details]
A CSV file for testing.

When I tried to open a CSV file with version 7.0.0.3, Libre Office repeatedly crashed, and I could not open the file.

While the same CSV file can be readily opened with version 6.4.6.2.

Excel can open the same file successfully.


Unicode (UTF-8)
Separated by Comma
Format quoted field as text
Comment 1 Ming Hua 2020-08-14 14:11:43 UTC
Can not reproduce with 7.0.0 on Windows 10:
Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU 线程: 2; 操作系统: Windows 10.0 Build 18363; 界面渲染: Skia/点阵; VCL: win
Locale: zh-CN (zh_CN); 界面: zh-CN
Calc: threaded

Attached example file opens and displays fine for me (with the specified UTF-8 encoding, comma as separater, and formatting quoted field as text).

@Kouichi Nakamura, maybe it's related to user profile, have you tried safe mode with version 7.0?
Comment 2 V Stuart Foote 2020-08-14 14:21:52 UTC
Can not confirm.
Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

Clean opening with or without making changes to default configuration Text Import... dialog, e.g. character set (UTF-8, system, or Windows 1252) or the separator options.

Perhaps a LO Help -> Safe mode restart
Comment 3 Kouichi Nakamura 2020-08-14 14:47:21 UTC
Thanks for testing.
I have downgraded LibreOffice to 6.4.6.2, but will try 7 again.
Comment 4 Roman Kuznetsov 2020-08-14 20:19:05 UTC
Try disable Skia before open your CSV (Tools-Options-LibreOffice-View dialog)

I'll set it as NEEDINFO
Comment 5 Kouichi Nakamura 2020-08-14 22:26:18 UTC
Safe mode worked.
There is a possibilty that it had something to do with Tab view. But once I cleaned the profile, it's OK now.
Thank you.