Bug 135793 - LO 7 and 6.4.6 cannot connect to MySQL database
Summary: LO 7 and 6.4.6 cannot connect to MySQL database
Status: RESOLVED DUPLICATE of bug 135202
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-16 08:22 UTC by I.E. Saridakis
Modified: 2020-08-16 17:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description I.E. Saridakis 2020-08-16 08:22:27 UTC
Description:
In Lo 7.0.0.3, connecting to a local MySQL database, which I've been using for years with LO fails with the following error, after providing the login credentials:
"The connection to the data source %DB_name could not be established. Plugin mysql_native_password could ne be loaded: /home/buildslave/-source/libo-core/connectivity/source/drivers/mysql/mysqlc_general:cxx:-119".
Also, when trying to connect using LO 6.4.6, produces the following error: "The connection to the data source %DB_name could not be established. Plugin mysql_native_password could not be loaded".
In LO 6.3.6.2, everything works as expected.
Also, connecting to the MySQl db is possible, through http and phpmyadmin.
I've changed MySQL's authentication method to SHA256 and sha2, or the db connection from localhost to 127.0.0.1 and vice-versa, but to no avail.

Actual Results:
Impossible to connect to the MySQL database

Expected Results:
Connect to and interact with the MySQL database


Reproducible: Always


User Profile Reset: Yes



Additional Info:
System details:
Linux Mint 20
libreoffice-sdbc-mysql, libreoffice-mysql-connector: 1:6.4.4.-0
mysql-server, mysql-connector-java (and -odbc): 8.0.21
Comment 1 Robert Großkopf 2020-08-16 14:42:24 UTC
Isn't this a duplicate of bug135202 ?
Comment 2 I.E. Saridakis 2020-08-16 17:39:53 UTC

*** This bug has been marked as a duplicate of bug 135202 ***