Bug 135883 - Opening a DOCX with footnotes with Character used instead of automatic numbering duplicates this character before footnote text
Summary: Opening a DOCX with footnotes with Character used instead of automatic number...
Status: RESOLVED DUPLICATE of bug 109382
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Footnote-Endnote
  Show dependency treegraph
 
Reported: 2020-08-18 15:43 UTC by Mike Kaganski
Modified: 2020-12-03 16:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2020-08-18 15:43:48 UTC
Opening a DOCX with footnotes which use Character instead of automatic numbering, the footnote text gets prepended with a copy of the character.

1. In a new Writer document, insert a footnote using Insert->Footnote and Endnote->Footnote or Endnote...
2. In the dialog, choose (*) Character, and put e.g. "a" there. Click OK.
3. Save the document as DOCX.
4. Test with some different application, e.g. MS Word, that the document is correct, and the footnote has only the "a" mark and no text.
5. Open the document in Writer

=> the footnote has "a" mark, and "a" character as the footnote's text.

Saving the document, the character gets written there. Repeated open-save-close will multiply the copies of the character.
Comment 1 Roman Kuznetsov 2020-08-18 16:17:42 UTC
confirm in

Version: 7.0.1.1 (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL
Comment 2 NISZ LibreOffice Team 2020-12-03 16:37:19 UTC
I saw this happening in the example file from bug #109382

*** This bug has been marked as a duplicate of bug 109382 ***