Bug 135890 - Chart Properties Sidebar broken when chart is double-clicked before opening the sidebar
Summary: Chart Properties Sidebar broken when chart is double-clicked before opening t...
Status: RESOLVED DUPLICATE of bug 94322
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected
Depends on:
Blocks:
 
Reported: 2020-08-18 17:59 UTC by Rafael Lima
Modified: 2022-06-16 05:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Image showing the broken inteface (118.83 KB, image/png)
2020-08-18 17:59 UTC, Rafael Lima
Details
File where I experienced the bug (31.28 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-08-18 18:00 UTC, Rafael Lima
Details
Screenshot of state after commit bisected in comment 3 (80.73 KB, image/png)
2020-08-30 20:29 UTC, Aron Budea
Details
Calc Chart Test (17.87 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-01-29 12:55 UTC, Rafael Lima
Details
Screen dump (65.54 KB, image/png)
2021-08-29 15:20 UTC, Colin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2020-08-18 17:59:37 UTC
Created attachment 164421 [details]
Image showing the broken inteface

I am using Calc 7.0.0.3 on Ubuntu 20.04 (Gnome 3.36 with Nvidia graphics).

When I add a chart to the spreadsheet, double-click it and then click the "Properties" button, the user interface appears broken with some gaps, as shown in the image file I attached to this bug report.

Steps to reproduce:
1) Select the data
2) Insert a chart based on the data (I used a line chart)
3) Double click the chart
4) Click the "Properties" button on the right sidebar
5) The "Properties" UI is broken

However, if I first click the Properties button and then double-click the chart, the user interface opens as expected.

This bug has happened on multiple ODS files, not only on this example.

I also attached the ODS file I was working on.
Comment 1 Rafael Lima 2020-08-18 18:00:56 UTC
Created attachment 164422 [details]
File where I experienced the bug
Comment 2 raal 2020-08-19 05:42:28 UTC
I can confirm with Version: 7.1.0.0.alpha0+
Build ID: ce6c6a5ad6c9dde09bb0bb0c51e16d828cfe0ef7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
Comment 3 raal 2020-08-19 21:31:20 UTC
Bisected to this commit, but after this this commit is half of the sidebar completely missing. Probably it was fixed later and this bug is related.
Adding Cc: to Caolán McNamara ; Could you possibly take a look at this one?
Thanks
 3401ce61dc5ca6e312b5c37adf86250b6316c94c is the first bad commit
commit 3401ce61dc5ca6e312b5c37adf86250b6316c94c
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Dec 19 22:50:53 2019 +0100

    source sha:e3a002c53a544de02e5119c5b0a2fd4f972156a8

author	Caolán McNamara <caolanm@redhat.com>	2019-12-17 17:27:30 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-12-19 22:07:19 +0100
commit e3a002c53a544de02e5119c5b0a2fd4f972156a8 (patch)
tree d6bd55210bb93fdc2aae2e398b63c3dddeb38326
parent e994b3fc3b2c9b7d39a715fc4d9453e06434d457 (diff)
get native gtk widgets in sidebars working
Comment 4 Aron Budea 2020-08-27 02:48:40 UTC
Actually adding Caolán to CC per comment 3.

Note that apart from this detail the chart sidebar has display issues that aren't regressions, see bug 94322, bug 103109 and bug 115147.
Comment 5 Caolán McNamara 2020-08-27 10:46:09 UTC
what exactly is bisected to e3a002c53a544de02e5119c5b0a2fd4f972156a8 ? My understanding is that the chart sidebar has always been somewhat broken since its creation
Comment 6 Aron Budea 2020-08-30 20:29:53 UTC
Created attachment 164900 [details]
Screenshot of state after commit bisected in comment 3

(In reply to Caolán McNamara from comment #5)
> what exactly is bisected to e3a002c53a544de02e5119c5b0a2fd4f972156a8 ? My
> understanding is that the chart sidebar has always been somewhat broken
> since its creation
Actually, there are multiple states. The difference between the current look and the one before the first commit is the gaps instead of pane titles that can be seen in attachment 164421 [details]. Only when the Properties sidebar is opened after getting in chart edit mode (ie. the generally broken state), if the sidebar is already open, all is fine.

The steps are the following:
1. After comment 3's commit, only Chart Type pane is shown (attaching screenshot). Titles aren't shown.

2. After the following commit, Chart Type and Elements panes are shown. Titles aren't shown.
https://cgit.freedesktop.org/libreoffice/core/commit/?id=8dd9dda69ffca6b167f690481070b8ee7bf7f8fd
author		Caolán McNamara <caolanm@redhat.com>	2019-12-20 15:40:52 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-12-21 11:27:48 +0100

"weld ChartElementsPanel"

3. After the following commit, it gets the current look, Chart Type, Elements and Area panes are shown. Titles aren't shown.
https://cgit.freedesktop.org/libreoffice/core/commit/?id=40fe5b93bc0838e04b46bfc7942d1ee6a2482ce0
author		Caolán McNamara <caolanm@redhat.com>	2020-01-02 14:45:32 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2020-01-06 16:44:21 +0100

"weld AreaPropertyPanel"
Comment 7 Caolán McNamara 2020-08-31 14:48:55 UTC
I don't think its a regression, just the underlying chart sidebar is broken since its inception and that's what needs to be fixed
Comment 8 Rafael Lima 2021-01-29 12:55:11 UTC
Created attachment 169269 [details]
Calc Chart Test

This bug is still present in LO 7.2 alpha.

I carried out a few tests and I think it may be related to the context in which the sidebar is opened. I prepared a file for testing (see the attached Calc Chart Test). In these tests I am using the KF5 VCL.

SCENARIO 1
1) Open the file
2) Open the Properties sidebar
3) Double-click the chart
4) Everything is fine! You can use the sidebar for editing the chart.

SCENARIO 2
1) Open the file
2) Close the sidebar
3) Double-click the chart
4) Open the properties sidebar
5) On the KF5 backend the sidebar opens, but if I click anywhere in the sidebar, it exits the chart editing mode, as though there were nothing in the sidebar

I do not have a good knowledge of the underlying code base here. But I think it has something to do with the context of the sidebar, because it doesn't seem to capture mouse events in Scenario 2.

Hope this helps figure out how to fix this bug.
Comment 9 Rafael Lima 2021-05-14 17:40:29 UTC
Still present in a recent LO 7.2 alpha build.

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 5f51b6f08c6ed6fb135b8d4999d6fb6a51fafa89
CPU threads: 16; OS: Linux 5.8; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-05-06_07:15:58
Calc: CL
Comment 10 Rafael Lima 2021-07-14 12:27:04 UTC
Still present in LibreOffice beta 1.

Version: 7.2.0.1 / LibreOffice Community
Build ID: 32efc3b7f3a71cfa6a7fa3f6c208333df48656cc
CPU threads: 16; OS: Linux 5.11; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: threaded
Comment 11 Colin 2021-08-29 15:20:25 UTC
Created attachment 174610 [details]
Screen dump

Version: 7.2.0.4 (x64) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: sv-SE (en_GB); UI: en-GB
Calc: threaded
I got this effect after trying to create a stock chart (also appears to be broken)
After creating the chart precisely as per the Libreoffice instructions and using the sample data I got the chart illustrated.
When I double-clicked the chart and selected chart type from the toolbar the sidebar was too small
I expanded it by dragging the boundary.
This placed it on top of the chart so I just used the bottom slide bar to move the sheet contents to the left.
I think it better illustrats the scope of the issue.

Perhaps you could advise if this is what the stock chart is supposed to do or whether I should file another bug report because I'm not convinced it worked.
Comment 12 Rafael Lima 2021-12-07 00:01:40 UTC
This bug is still present in LO 7.3 beta 1.

Inserting a chart with the sidebar hidden, then double-click the chart and open the Properties sidebar will break the sidebar.

System info:
Version: 7.3.0.0.beta1 / LibreOffice Community
Build ID: 436f14c25ec1847646b953cf13d0db4f7ca3be57
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: threaded
Comment 13 Rafael Lima 2022-05-21 19:05:21 UTC
This bug is still present in LO 7.4 from master.

IMO this should be viewed as a critical bug since it makes it impossible to use the sidebar while editing charts (which is a common workflow for many users).

System info:
Version: 7.4.0.0.alpha1+ / LibreOffice Community
Build ID: ad6905f9a09c63712ba0aaffc700923246d21e55
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: CL
Comment 14 Aron Budea 2022-05-22 04:01:53 UTC
(In reply to Rafael Lima from comment #13)
> [...] it makes it impossible to
> use the sidebar while editing charts (which is a common workflow for many
> users).
Not really, it's fine if the sidebar is already open when the user enters chart edit mode.
Comment 15 Aron Budea 2022-06-16 05:56:30 UTC
Let's consolidate these into bug 94322, as they have the same root cause.

*** This bug has been marked as a duplicate of bug 94322 ***