Bug 135892 - Naming of the Style inspector. Should it be Style Inspector/ style explorer/ style examiner; and how well does it translate
Summary: Naming of the Style inspector. Should it be Style Inspector/ style explorer/ ...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Styles_Inspector
  Show dependency treegraph
 
Reported: 2020-08-18 18:35 UTC by Telesto
Modified: 2020-09-07 14:13 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot with French UI (30.98 KB, image/png)
2020-08-18 18:51 UTC, Julien Nabet
Details
screenshot with keyid (39.36 KB, image/png)
2020-08-18 18:54 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-18 18:35:51 UTC
Description:
While reporting an issue with the style inspector I accidentally used style explorer. Which made me think a bit. From user perspective is more an instrument for explorer the used styles. So style explorer or maybe styles examiner. The latter might translate better. 
Of course you're inspecting styles; but an Inspector maybe have some kind of negative connotation. Prüfer (DE) Kontrolleure (DE) are the most loved people; people who always complain about something not being right. Of course maybe my personal (slightly exaggerated) feeling; the context can make it more acceptable. 

Related to translations, has 'style inspector' checked by the translation department? To get something which translates well in most/all languages. There are number of cases where they translations end up being creepily awkward. Skia/Raster being Skia/Rooster (Dutch) for example

I would prefer to check with translation in advance (or see what they come up with). 

 

Steps to Reproduce:
-

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 Telesto 2020-08-18 18:41:39 UTC
Inspector does remind me bit of Inspector Gadget ;D
https://en.wikipedia.org/wiki/Inspector_Gadget_(1983_TV_series)
Comment 2 Telesto 2020-08-18 18:42:59 UTC
@Julien
How well does Style Inspector translate into French?
Comment 3 Julien Nabet 2020-08-18 18:51:36 UTC
Created attachment 164426 [details]
screenshot with French UI

On pc Debian x86-64 with master sources updated today, I got quite a lot of strings not translated.
Comment 4 Julien Nabet 2020-08-18 18:54:29 UTC
Created attachment 164427 [details]
screenshot with keyid

keyid view shows a different result.
Comment 5 Telesto 2020-08-18 19:28:39 UTC
I checked a few languages.. but translations are surely not 'harmonic'. There are quite some twists and turns. 

Styles inspektor translated as 'Formatvorlagen' German. Which is the same as 'Styles' Formatvorlagen. Dutch has same issue; both called "Opmaakprofielen".

Spanish/French/English/Norwegian are OK; translation wise.. not sure how natural/common 'Inspector' usage is.
Comment 6 Heiko Tietze 2020-09-04 18:52:42 UTC
https://www.merriam-webster.com/ knows best:

Definition of inspect
1 : to view closely in critical appraisal : look over
2 : to examine officially inspects the barracks every Friday

Definition of explore
1a : to investigate, study, or analyze
b : to become familiar with by testing or experimenting explore new cuisines
2 : to travel over (new territory) for adventure or discovery
3 : to examine especially for diagnostic purposes explore the wound

Definition of examine
1a : to inspect closely
b : to test the condition of
c : to inquire into carefully : investigate
2a : to interrogate closely examine a prisoner
b : to test by questioning in order to determine progress, fitness, or knowledge

My non-native sense of language is #1 for inspect, #2 for explore, and 1b for examine. Wouldn't change the name => WF.
Comment 7 Telesto 2020-09-04 20:29:13 UTC
(In reply to Heiko Tietze from comment #6)
Is there some who manages number of languages? Inspector will work number of country's. I certainly going to dislike the Dutch translation. I probably can't stand it. Hover such a small language is of course not representative for the whole world. 

Explorer should be available by now in nearly all languages: (Internet Explorer; Windows Explorer). 

Is there not a contact person for translation questions?
Comment 8 Shivam Kumar Singh 2020-09-05 08:17:45 UTC
Just to add a point, The similar tool used by MSO is also called "Styles Inspector"
Comment 9 Telesto 2020-09-05 08:25:38 UTC
(In reply to Shivam Kumar Singh from comment #8)
> Just to add a point, The similar tool used by MSO is also called "Styles
> Inspector"

Pretty convincing point, not aware of that.
Comment 10 sophie 2020-09-07 12:40:54 UTC
(In reply to Telesto from comment #7)
> (In reply to Heiko Tietze from comment #6)
> Is there some who manages number of languages? Inspector will work number of
> country's. I certainly going to dislike the Dutch translation. I probably
> can't stand it. Hover such a small language is of course not representative
> for the whole world. 
> 
> Explorer should be available by now in nearly all languages: (Internet
> Explorer; Windows Explorer). 
> 
> Is there not a contact person for translation questions?

Inspector is more precise in my view than Explorer so also WFM. If you disagree with the Dutch translation, then contact the team and give them your feedback either on the global/local list or Weblate. BTW, there is no such thing as small languages, all are equals :)
Comment 11 Heiko Tietze 2020-09-07 14:08:36 UTC
Let's keep it an "Inspector".
Comment 12 Adolfo Jayme 2020-09-07 14:13:52 UTC
I’d second Sophie’s point and resolve as “not a bug”, given that “inspect” is already used by all major web browsers for the option that lets you see and edit the source code of a page.

For translators (like me!) who might sometimes have difficulty finding the right term, I recommend https://microsoft.com/language. With that tool I can see that Microsoft has translated this particular term as “Stijlcontrole” https://www.microsoft.com/en-us/language/Search?&searchTerm=inspector&langID=155&Source=true&productid=0