Bug 135914 - ui: 'insert column' is not offered on right-click on column header after deleting a column from a filtered range
Summary: ui: 'insert column' is not offered on right-click on column header after dele...
Status: RESOLVED DUPLICATE of bug 57351
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-19 10:58 UTC by b.
Modified: 2021-04-30 16:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample file (8.51 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-08-19 11:00 UTC, b.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description b. 2020-08-19 10:58:35 UTC
Description:
the title says it all, 

this bug is a 'spin-off' from tdf#48025, 

normally on right click on a column header (the letter 'A' or 'B' ...) you get options and among them 'insert column before' and 'insert column after', 

after deleting a column from a filtered range theese two options are blocked for the whole sheet, 

take sample sheet from next comment, filter column E (Col_B) to not show all rows, delete col E, right click on the header of col G, options to insert columns not offered, 

Steps to Reproduce:
see description, the bug is older, i didn't check when it started, 

Actual Results:
option not offered, 

Expected Results:
option offered as without deleting the column, 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc: CL
Comment 1 b. 2020-08-19 11:00:16 UTC
Created attachment 164463 [details]
sample file
Comment 2 m.a.riosv 2020-08-19 12:05:55 UTC
Don't need to delete any column, only filtering data, the option for insert it's  not visible.
Comment 3 Gunter Ohrner 2021-04-30 16:27:31 UTC
That's a duplicate of Bug #57351.

*** This bug has been marked as a duplicate of bug 57351 ***