Download it now!
Bug 135950 - Immediate CRASH: Highlight multiple cells in a Writer table and select FORMAT -> CHARACTER
Summary: Immediate CRASH: Highlight multiple cells in a Writer table and select FORMAT...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0 target:6.4.7 target:7.0.2
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2020-08-20 15:24 UTC by Gerry
Modified: 2020-09-29 15:02 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Immediate-crash-change-characters-of-multiple-cells.odt (11.31 KB, application/vnd.oasis.opendocument.text)
2020-08-20 15:24 UTC, Gerry
Details
bt with debug symbols (10.58 KB, text/plain)
2020-08-20 21:14 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2020-08-20 15:24:14 UTC
Created attachment 164499 [details]
Immediate-crash-change-characters-of-multiple-cells.odt

On macOS, following action in Writer leads to an immediate crash of LibreOffice

Steps to reproduce:
- Open attached file
- Select at least two cells in the table 
- Go to FORMAT -> CHARACTER
-> Immediate crash

Reproducibility: Always


System:
LibreOffice Version: 7.0.0.3
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU-Threads: 4; BS: Mac OS X 10.15.6; UI-Render: Standard; VCL: osx
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Calc: threaded

macOS version: Catalina 10.15.6
Comment 1 Julien Nabet 2020-08-20 21:14:44 UTC
Created attachment 164512 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I got an assertion.
Comment 2 Julien Nabet 2020-08-20 21:16:22 UTC
I must recognize I don't have crash with 7.0.1.1 LO Debian testing package (so not a debug build).
Comment 3 Gerry 2020-08-24 18:18:16 UTC
Would it be possible to set the importance of this bug to "critical", since it deals with a CRASH of LibreOffice? Thanks

https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Severity
Comment 4 Telesto 2020-08-24 18:27:57 UTC
(In reply to Gerry from comment #3)
> Would it be possible to set the importance of this bug to "critical", since
> it deals with a CRASH of LibreOffice? Thanks
> 
> https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Severity

Would you mind to try a pre-release 
https://dev-builds.libreoffice.org/pre-releases/ -> MacOS; scroll down to bottom 7.0.1.1 should show up

I don't get a crash on Windows with 7.1 (Master)
Comment 5 Gerry 2020-08-24 19:25:18 UTC
(In reply to Telesto from comment #4)
> (In reply to Gerry from comment #3)
> > Would it be possible to set the importance of this bug to "critical", since
> > it deals with a CRASH of LibreOffice? Thanks
> > 
> > https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Severity
> 
> Would you mind to try a pre-release 
> https://dev-builds.libreoffice.org/pre-releases/ -> MacOS; scroll down to
> bottom 7.0.1.1 should show up
> 
> I don't get a crash on Windows with 7.1 (Master)


Same problem with 7.0.1.1 --> Immediate crash

Version: 7.0.1.1
Build ID: <buildversion>
CPU threads: 4; OS: Mac OS X 10.15.6; UI render: default; VCL: osx
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded
Comment 6 Theodore Vaida 2020-09-08 19:10:49 UTC
I was seeing this one too in 6.4.x on OS X (10.14.6) - updating to version 7.0.1.2 appears to have fixed it.
Comment 7 Gerry 2020-09-09 11:20:09 UTC
Same problem still with 7.0.1.2 --> Immediate crash


Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Mac OS X 10.15.6; UI render: default; VCL: osx
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Calc: threaded
Comment 8 Xisco Faulí 2020-09-10 07:55:14 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=3c367de9893b1e2d352585a42cbbd25052bb7376

author	Michael Stahl <Michael.Stahl@cib.de>	2019-08-09 18:43:36 +0200
committer	Caolán McNamara <caolanm@redhat.com>	2019-08-10 12:38:08 +0200
commit	3c367de9893b1e2d352585a42cbbd25052bb7376 (patch)
tree	02045c4f68150560374b5e90a37d11fc0cf4de9b
parent	ba61c3174bc24bc03e3f72fbc8d102b3312b5ff6 (diff)
sw: fix ~SwIndexReg asserts on ODF export of ooo83072-1.odt

Bisected with: bibisect-linux64-6.4

Adding Cc: to Michael Stahl
Comment 9 Xisco Faulí 2020-09-10 07:56:02 UTC
@Caolán, since this issue also concerns the UI, I thought you might be interested
Comment 10 Caolán McNamara 2020-09-10 09:06:59 UTC
The selected text is pulled out of the document to be used as the preview text. While the bisect identified the assert the crash is reported from an NDEBUG build so 3c367de9893b1e2d352585a42cbbd25052bb7376 didn't make the NDEBUG case start crashing, maybe 3c367de9893b1e2d352585a42cbbd25052bb7376 or beec1594587d0bf1ea2268f9a435c948b5580278 or something like that.

I find https://gerrit.libreoffice.org/c/core/+/102368 makes it not crash and it seems fairly reasonable to me
Comment 11 Xisco Faulí 2020-09-10 09:20:28 UTC
(In reply to Caolán McNamara from comment #10)
> I find https://gerrit.libreoffice.org/c/core/+/102368 makes it not crash and
> it seems fairly reasonable to me

I do confirm the patch fixes the issue for me
Comment 12 Commit Notification 2020-09-10 11:53:59 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/88aef1966ef1e5018bca54ccd59bb9e3c2f95b76

tdf#135950 crash in format->character with selected text in table

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Caolán McNamara 2020-09-10 11:54:48 UTC
fixed like that in master, backports to 7-0 and 6-4 in gerrit
Comment 14 Commit Notification 2020-09-10 13:30:48 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6d790ba76991be3a01f40636fa3b9e220a8d73d8

tdf#135950: sw: Add UItest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-09-10 13:32:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/217d6ee31d6c892af63931ca4fc4158b8e713640

tdf#135950 crash in format->character with selected text in table

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2020-09-10 13:32:18 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/7c140177879d259a6d41ea2383105b5eabef958c

tdf#135950 crash in format->character with selected text in table

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Xisco Faulí 2020-09-29 15:02:26 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: cd85546a2fbdade42f80fd3b6bd650791db9f32d
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: tr-TR (en_US.UTF-8); UI: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!