Bug 135977 - Rename and Reorder Template Menu to make it more intuitive.
Summary: Rename and Reorder Template Menu to make it more intuitive.
Status: RESOLVED DUPLICATE of bug 137906
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-08-21 08:57 UTC by Clarc
Modified: 2021-04-20 14:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Clarc 2020-08-21 08:57:48 UTC
Description:
To improve the user-friendliness, I suggest the following:

Reorder the Template menu (the three options that show up when you go on File -> Templates), so that 'Manage Templates' is the first option. 
Additionally, it should be renamed to something similar to 'Use Template' or 'Document from Template'. Maybe, the best option is to switch the naming of 'Manage Templates' and 'Open Template'.

Why?
POSITION: If we think about which option is most used, when regularly using LO, it will be the currently named 'Manage Templates', because a user will most likely actually use templates than create or open new ones. Therefore, navigating to the most used option should be facilitated by placing that option at the top. This would also show new users, that this is the option, they are (most likely) searching for.
'Open Template' being at the top implies that this is the main option to choose. When users click on it, nice, a template opened. They work with it and once they save, they will just have overwritten their template and have no idea where to find their document.

NAMING: Unless I have overlooked something major, 'Manage Templates' is the main option to create a new document, based on a template. Unfortunately, 'Manage Templates' doesn't reflect this feature at all. 'Manage Templates' sounds like "Edit & Reorder Templates". Which is really confusing to new users.

To recap:
1. Place 'Manage Templates' on the top of the three options [Manage Template, Open Template, Save as Template]
2. Rename 'Manage Templates' with a term, which more closely reflects it's most common use: making a document from the basis of a template.

Actual Results:
 

Expected Results:
 


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Clarc 2020-08-21 09:02:32 UTC
(Even the command to get to 'Manage Templates' reflects its use: Ctrl + Shift + N
This literally is the shortcut for "New Document" + Shift. It would make sense to name the menu-entry accordingly.)
Comment 2 Clarc 2020-08-21 09:19:09 UTC
Also, 'Open Template' might be more aptly named 'Edit Template'.
Comment 3 Heiko Tietze 2021-04-14 09:11:27 UTC
(In reply to Clarc from comment #0)
> POSITION: ... option is most used
Not against this idea but just mentioning that generic properties are at the bottom of context menus.

> NAMING: ... 'Use Template' or 'Document from Template'...switch the naming of 'Manage Templates' and 'Open Template'
Not excited about this idea, maybe used to the term "manage". Switching labels would be a major pitfall for translators and users.
Comment 4 sdc.blanco 2021-04-14 22:11:30 UTC
(In reply to Clarc from comment #0)
Thanks for your suggestions and interest. Improvements are worthwhile, but maybe a more comprehensive approach is preferable.

-  Naming issues
(a)  About comment 2.  "Open Template" will be "Edit Template" in 7.2 (see bug 138621, comment 8)

(b) Template Manager has multiple purposes (including setting a default template, renaming and deleting templates, putting them in categories, moving them between categories, etc.), so it is just as problematic to rename the command to something that signals primarily "open a document based on a template" -- because then it "hides" all the other management functions (see next point).

- Position issue
Changing command position in the Template submenu might be appropriate if nothing further was done in relation to templates. But maybe the UI should be improved to (a) make it easier to use templates and (b) unnecessary to use template manager (Ctrl+Shift+N) as the primary (only) way to open templates (see bug 137906).

With that approach, the template manger would go back (become) primarily a dialog to manage templates, and then its name and position would become less important, in relation to opening new documents with templates.

My proposal: Given that the OP is focused on "improve the user-friendliness", consider closing this ticket as a duplicate of bug 137906, as way to indicate/register interest for improving ease of using/selecting templates when opening new documents (and then "position" can be considered in light of other planned UI changes).
Comment 5 Heiko Tietze 2021-04-20 14:44:25 UTC
(In reply to sdc.blanco from comment #4)
> My proposal: Given that the OP is focused on "improve the
> user-friendliness", consider closing this ticket as a duplicate of bug
> 137906...

Clarc, you are very welcome to join the discussion on the other ticket.

*** This bug has been marked as a duplicate of bug 137906 ***