Bug 135997 - SPECIAL CHARACTER DIALOG: Crash in: SvxCharacterMap::updateRecentCharControl()
Summary: SPECIAL CHARACTER DIALOG: Crash in: SvxCharacterMap::updateRecentCharControl()
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:7.1.0 target:7.0.2 target:7.2....
Keywords:
: 137699 (view as bug list)
Depends on:
Blocks: Special-Character
  Show dependency treegraph
 
Reported: 2020-08-21 19:32 UTC by qwertyou012345678910
Modified: 2021-05-21 17:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["SvxCharacterMap::updateRecentCharControl()"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description qwertyou012345678910 2020-08-21 19:32:36 UTC
This bug was filed from the crash reporting server and is br-d77d43cd-e6f3-44ca-9301-ca84b2203781.

Overview: Attempting to access the special character menu causes a crash to desktop


Steps to Reproduce: Attempt to open the special character menu

Actual Results: CTD

Expected Results: Open the special character menu

Build Date & Hardware: 08-21-2020 on Windows 10 current version
=========================================
Comment 1 Dieter 2020-08-23 14:57:17 UTC
I can't confirm it with

Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded

I've tried
a) Insert => Special character; Result: No crash
b) Click special cahracter icon in toolbar; Result : No crash
Comment 2 qwertyou012345678910 2020-08-23 15:21:17 UTC
(In reply to Dieter from comment #1)
> I can't confirm it with
> 
> Version: 7.0.0.3 (x64)
> Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
> CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL:
> win
> Locale: de-DE (de_DE); UI: en-GB
> Calc: threaded
> 
> I've tried
> a) Insert => Special character; Result: No crash
> b) Click special cahracter icon in toolbar; Result : No crash

Is there any additional information you believe would be useful?
Comment 3 Telesto 2020-08-24 18:10:00 UTC
You can try to reset user profile:
Go to Help - Restart in Safe Mode - Factory Settings.

Please let us know if it works (or not)
Comment 4 Mike Kaganski 2020-08-24 22:05:17 UTC
*Hopefully* https://gerrit.libreoffice.org/c/core/+/101162 would fix this.
Comment 5 Commit Notification 2020-08-24 22:49:23 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3b386467f2d4b2b96b7e697d9f5b133819f6180e

tdf#135997: properly check loop condition

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Dieter 2020-08-25 06:07:30 UTC
(In reply to Mike Kaganski from comment #4)
> *Hopefully* https://gerrit.libreoffice.org/c/core/+/101162 would fix this.

Mike, status is still UNCONFIRMED. Is this correct, or should it be RESOLVED FIXED?
Comment 7 Mike Kaganski 2020-08-25 06:57:33 UTC
(In reply to Dieter from comment #6)

I could not repro the problem, and the fix is based on my understanding of a possible problem in the code (but then, I don't know if the iterators in condition I tried to fix could ever be in different-length containers). So I at least wanted some confirmation from reporter(s) before closing.

The problem in bug 136074 seems to be the same, so possibly qualifies to make this NEW?
Comment 8 Dieter 2020-08-25 07:00:32 UTC
OK., let's wait for input from the bug reporter.
Comment 9 Commit Notification 2020-08-25 08:12:24 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/fc7b4bfeba39a2479c9a2c9c8ef5ced5ab3c0de7

tdf#135997: properly check loop condition

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 qwertyou012345678910 2020-08-27 16:46:03 UTC
(In reply to Telesto from comment #3)
> You can try to reset user profile:
> Go to Help - Restart in Safe Mode - Factory Settings.
> 
> Please let us know if it works (or not)

Restarting in safe mode fixes the issue. I uninstalled then reinstalled LibreOffice using the installation wizard and the issue persisted. The issue is not present for me under the following information:

Version: 7.1.0.0.alpha0+ (x64)
Build ID: cac7ad2d011eb6602b6c9702dddb76d129f093c8
CPU threads: 16; OS: Windows 10.0 Build 18362; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 11 Xisco Faulí 2020-10-23 10:13:24 UTC
*** Bug 137699 has been marked as a duplicate of this bug. ***
Comment 12 mathias.micheel 2020-11-15 15:29:20 UTC
This bug is still ocurring for me:
crashreport.libreoffice.org/stats/crash_details/713ebb2a-fd52-4bbf-acc8-4211a89618a7

Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 12; OS: Windows 10.0 Build 19041; UI render: default; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded

In safe mode, I can access the special characters menu.
Comment 13 Dieter 2020-11-22 11:24:12 UTC
(In reply to mathias.micheel from comment #12)
> In safe mode, I can access the special characters menu.

So it seems, that there is a corruption in the user profile. Could you please reset your Libreoffice profile (https://wiki.documentfoundation.org/UserProfile) and re-test?
Comment 14 mathias.micheel 2020-11-23 08:15:21 UTC
(In reply to Dieter from comment #13)
> (In reply to mathias.micheel from comment #12)
> > In safe mode, I can access the special characters menu.
> 
> So it seems, that there is a corruption in the user profile. Could you
> please reset your Libreoffice profile
> (https://wiki.documentfoundation.org/UserProfile) and re-test?

This did indeed solve the issue for me. I will test with another computer on which I encountered this bug and report if it still persists.
Comment 15 Pietro Battiston 2021-01-23 16:17:35 UTC
I can confirm with 6.0.7-0ubuntu0.18.04.10 , including that the problem was solved after resetting the user profile.
Comment 16 Dieter 2021-02-02 07:59:06 UTC
Mike, it seems, that your patch fixed this bug. Can we close it as RESOLVED FIXED?
Comment 17 Mike Kaganski 2021-02-02 08:13:43 UTC
(In reply to Dieter from comment #16)

I don't know if my patch had fixed it. If there were no new reports for 7.0.2+ I could think so, but there's c#12 which seems to suggest that 7.0.3.1 still had the problem that should had *not* happen there.

Note that c#3, c#10, c#14 and c#15 are irrelevant to the fix, since the problem there was indeed that *some condition in recent list* triggered the bug, and resetting the profile naturally resets the recent list. This is like "I have this file crashing" -> "delete the file; does it crash now?".
Comment 18 Mike Kaganski 2021-02-02 08:46:12 UTC
(In reply to Mike Kaganski from comment #17)
> but there's c#12 which seems to suggest that
> 7.0.3.1 still had the problem that should had *not* happen there.

On the other hand, br-713ebb2a-fd52-4bbf-acc8-4211a89618a7 from comment 12 is different from br-d77d43cd-e6f3-44ca-9301-ca84b2203781 from comment 0, so no idea if the problem in comment 12 is actually related. It still might be, e.g. my patch could had fixed one place, and now it started to fail a bit later because of still not expecting that condition.

A way to repro is needed to be sure. If it will not happen anymore, then it should be closed. If it appears again, a copy of the problematic profile could be useful, to try to see what there in the recent list might be special.
Comment 19 Mike Kaganski 2021-04-28 08:35:14 UTC
Looks like this (or a similar) problem is reported at https://ask.libreoffice.org/en/question/306592/ for 7.1.2.2.
Comment 20 Mike Kaganski 2021-04-28 09:30:54 UTC
FTR: to repro the problem (both in the dialog prior to https://git.libreoffice.org/core/commit/fc7b4bfeba39a2479c9a2c9c8ef5ced5ab3c0de7, and now in toolbar control), edit the registrymodifications.xcu, and make sure that the two elements - RecentCharacterFontList and RecentCharacterList - contain different number of elements.
Comment 21 Commit Notification 2021-04-29 05:17:53 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b27de500b1412bacefc7144b5222c307ca1ae0fe

tdf#135997: fix toolbar control

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2021-04-29 05:18:04 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b6ab5914d8b2fc7041430796890f086f8e3e6369

tdf#135997: make sure that the two lists are same length

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2021-04-29 09:08:22 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/1cbb39dc112117c4038ac63074c17154baa1d593

tdf#135997: fix toolbar control

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2021-04-29 09:40:11 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/b672adaf5a4604aa09322034e4f5c151a4dc1314

tdf#135997: make sure that the two lists are same length

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2021-04-29 12:40:24 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/31736f5f0abc09eb4066d09fd9e7394d844f9748

tdf#135997: fix toolbar control

It will be available in 7.0.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Commit Notification 2021-05-02 18:50:55 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-0-6":

https://git.libreoffice.org/core/commit/b7a222f00554f6768aa91250324c3284ad041174

tdf#135997: fix toolbar control

It will be available in 7.0.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.